summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-01-07 12:21:53 +0000
committerMichał Górny <mgorny@gentoo.org>2011-01-07 12:21:53 +0000
commit14ea73ab59bb9d7b696dde996830d87560855d51 (patch)
tree1e586e7d2bd5057fff647e516004e575591ccc58 /app-portage
parentFixes for bug #350949 (diff)
downloadgentoo-2-14ea73ab59bb9d7b696dde996830d87560855d51.tar.gz
gentoo-2-14ea73ab59bb9d7b696dde996830d87560855d51.tar.bz2
gentoo-2-14ea73ab59bb9d7b696dde996830d87560855d51.zip
Version bump. Fixes #349108 (package.accept_keywords support) and #349207 ('*' special keyword), adds a bash-completion script.
(Portage version: 2.2.0_alpha12_p8/cvs/Linux x86_64)
Diffstat (limited to 'app-portage')
-rw-r--r--app-portage/flaggie/ChangeLog8
-rw-r--r--app-portage/flaggie/flaggie-0.0.4.ebuild42
2 files changed, 49 insertions, 1 deletions
diff --git a/app-portage/flaggie/ChangeLog b/app-portage/flaggie/ChangeLog
index e0ba2ad6dd55..98693e269226 100644
--- a/app-portage/flaggie/ChangeLog
+++ b/app-portage/flaggie/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-portage/flaggie
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-portage/flaggie/ChangeLog,v 1.12 2011/01/06 15:51:12 c1pher Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-portage/flaggie/ChangeLog,v 1.13 2011/01/07 12:21:53 mgorny Exp $
+
+*flaggie-0.0.4 (07 Jan 2011)
+
+ 07 Jan 2011; Michał Górny <mgorny@gentoo.org> +flaggie-0.0.4.ebuild:
+ Version bump. Fixes #349108 (package.accept_keywords support) and #349207
+ ('*' special keyword), adds a bash-completion script.
06 Jan 2011; Dane Smith <c1pher@gentoo.org> flaggie-0.0.3.ebuild:
Tested on arm. Marking ~arm.
diff --git a/app-portage/flaggie/flaggie-0.0.4.ebuild b/app-portage/flaggie/flaggie-0.0.4.ebuild
new file mode 100644
index 000000000000..a2a51293c3c6
--- /dev/null
+++ b/app-portage/flaggie/flaggie-0.0.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-portage/flaggie/flaggie-0.0.4.ebuild,v 1.1 2011/01/07 12:21:53 mgorny Exp $
+
+EAPI=3
+PYTHON_DEPEND="*:2.6"
+SUPPORT_PYTHON_ABIS=1
+RESTRICT_PYTHON_ABIS="2.4 2.5"
+
+inherit base distutils
+
+DESCRIPTION="A smart CLI mangler for package.* files"
+HOMEPAGE="https://github.com/mgorny/flaggie/"
+SRC_URI="http://cloud.github.com/downloads/mgorny/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1.8.3"
+
+src_prepare() {
+ base_src_prepare
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+
+ insinto /usr/share/bash-completion
+ newins contrib/bash-completion/${PN}.bash-completion ${PN} || die
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+
+ ewarn "Please denote that flaggie creates backups of your package.* files"
+ ewarn "before performing each change through appending a single '~'."
+ ewarn "If you'd like to keep your own backup of them, please use another"
+ ewarn "naming scheme (or even better some VCS)."
+}