summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKarol Wojtaszek <sekretarz@gentoo.org>2006-03-16 17:40:27 +0000
committerKarol Wojtaszek <sekretarz@gentoo.org>2006-03-16 17:40:27 +0000
commit401b319551cdaa9a8af14c6aad682ec56e537e66 (patch)
tree5331caa7b764fd0e849b515645a4ed0df14a5284 /app-pda
parent~amd64 keyworded (diff)
downloadgentoo-2-401b319551cdaa9a8af14c6aad682ec56e537e66.tar.gz
gentoo-2-401b319551cdaa9a8af14c6aad682ec56e537e66.tar.bz2
gentoo-2-401b319551cdaa9a8af14c6aad682ec56e537e66.zip
Added gcc-4 patch, ~amd64 keyworded
(Portage version: 2.1_pre6-r3)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/multisync/ChangeLog6
-rw-r--r--app-pda/multisync/files/multisync-gcc4.patch88
-rw-r--r--app-pda/multisync/multisync-0.83_pre20050414-r3.ebuild13
3 files changed, 103 insertions, 4 deletions
diff --git a/app-pda/multisync/ChangeLog b/app-pda/multisync/ChangeLog
index 3a9ffefdbe28..62190175cd50 100644
--- a/app-pda/multisync/ChangeLog
+++ b/app-pda/multisync/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-pda/multisync
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/multisync/ChangeLog,v 1.28 2006/02/09 17:07:38 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/multisync/ChangeLog,v 1.29 2006/03/16 17:40:27 sekretarz Exp $
+
+ 16 Mar 2006; Karol Wojtaszek <sekretarz@gentoo.org>
+ +files/multisync-gcc4.patch, multisync-0.83_pre20050414-r3.ebuild:
+ Added gcc-4 patch, ~amd64 keyworded
09 Feb 2006; Andrej Kacian <ticho@gentoo.org>
multisync-0.83_pre20050414-r2.ebuild,
diff --git a/app-pda/multisync/files/multisync-gcc4.patch b/app-pda/multisync/files/multisync-gcc4.patch
new file mode 100644
index 000000000000..30fc12eb498c
--- /dev/null
+++ b/app-pda/multisync/files/multisync-gcc4.patch
@@ -0,0 +1,88 @@
+--- multisync/plugins/ldap_plugin/src/xml.c 2003-12-02 09:36:28.000000000 +1000
++++ multisync.wade/plugins/ldap_plugin/src/xml.c 2005-05-10 23:34:02.000000000 +1000
+@@ -55,7 +55,7 @@
+ }
+
+ while (cur != NULL) {
+- xmlstr = xmlNodeListGetString(doc, cur->xmlChildrenNode, 1);
++ xmlstr = ( char * ) xmlNodeListGetString( doc, cur->xmlChildrenNode, 1);
+
+ if ((!xmlStrcmp(cur->name, (const xmlChar *)"serverport"))) {
+ conn->serverport = atoi(xmlstr);
+@@ -130,8 +130,8 @@
+ char port[256], debuglevel[256], scope[256], encryption[256], write[256], anonymous[256];
+ ldap_debug(conn, 2, "Saving state to file %s", conn->statefile);
+
+- doc = xmlNewDoc("1.0");
+- doc->children = xmlNewDocNode(doc, NULL, "config", NULL);
++ doc = xmlNewDoc( (const xmlChar *) "1.0");
++ doc->children = xmlNewDocNode(doc, NULL, (const xmlChar *) "config", NULL);
+
+ snprintf(port, 256, "%i", conn->serverport);
+ snprintf(debuglevel, 256, "%i", conn->debug_level);
+@@ -140,18 +140,18 @@
+ snprintf(write, 256, "%i", conn->write);
+ snprintf(anonymous, 256, "%i", conn->anonymous);
+
+- xmlNewChild(doc->children, NULL, "servername", conn->servername);
+- xmlNewChild(doc->children, NULL, "serverport", port);
+- xmlNewChild(doc->children, NULL, "binddn", conn->binddn);
+- xmlNewChild(doc->children, NULL, "pwd", conn->pwd);
+- xmlNewChild(doc->children, NULL, "searchbase", conn->searchbase);
+- xmlNewChild(doc->children, NULL, "filter", conn->filter);
+- xmlNewChild(doc->children, NULL, "scope", scope);
+- xmlNewChild(doc->children, NULL, "debuglevel", debuglevel);
+- xmlNewChild(doc->children, NULL, "authmech", conn->authmech);
+- xmlNewChild(doc->children, NULL, "encryption", encryption);
+- xmlNewChild(doc->children, NULL, "write", write);
+- xmlNewChild(doc->children, NULL, "anonymous", anonymous);
++ xmlNewChild(doc->children, NULL, (const xmlChar *) "servername", (const xmlChar *) conn->servername);
++ xmlNewChild(doc->children, NULL, (const xmlChar *) "serverport", (const xmlChar *) port);
++ xmlNewChild(doc->children, NULL, (const xmlChar *) "binddn", (const xmlChar *) conn->binddn);
++ xmlNewChild(doc->children, NULL, (const xmlChar *) "pwd", (const xmlChar *) conn->pwd);
++ xmlNewChild(doc->children, NULL, (const xmlChar *) "searchbase", (const xmlChar *) conn->searchbase);
++ xmlNewChild(doc->children, NULL, (const xmlChar *) "filter", (const xmlChar *) conn->filter);
++ xmlNewChild(doc->children, NULL, (const xmlChar *) "scope", (const xmlChar *) scope);
++ xmlNewChild(doc->children, NULL, (const xmlChar *) "debuglevel", (const xmlChar *) debuglevel);
++ xmlNewChild(doc->children, NULL, (const xmlChar *) "authmech", (const xmlChar *) conn->authmech);
++ xmlNewChild(doc->children, NULL, (const xmlChar *) "encryption", (const xmlChar *) encryption);
++ xmlNewChild(doc->children, NULL, (const xmlChar *) "write", (const xmlChar *) write);
++ xmlNewChild(doc->children, NULL, (const xmlChar *) "anonymous", (const xmlChar *) anonymous);
+
+ xmlSaveFile(conn->statefile, doc);
+ xmlFreeDoc(doc);
+@@ -180,10 +180,10 @@
+
+ while (child) {
+ if ((!xmlStrcmp(child->name, (const xmlChar *)"modifyTimestamp"))) {
+- entry->modifyTimestamp = xmlNodeListGetString(doc, child->xmlChildrenNode, 1);
++ entry->modifyTimestamp = (char *) xmlNodeListGetString( doc, child->xmlChildrenNode, 1);
+ }
+ if ((!xmlStrcmp(child->name, (const xmlChar *)"uid"))) {
+- entry->uid = xmlNodeListGetString(doc, child->xmlChildrenNode, 1);
++ entry->uid = (char *) xmlNodeListGetString(doc, child->xmlChildrenNode, 1);
+ }
+
+ child = child->next;
+@@ -282,16 +282,16 @@
+
+ ldap_debug(conn, 2, "Saving head data to file %s", conn->dbfile);
+
+- doc = xmlNewDoc("1.0");
+- doc->children = xmlNewDocNode(doc, NULL, "ldap_entries", NULL);
++ doc = xmlNewDoc( (const xmlChar *) "1.0");
++ doc->children = xmlNewDocNode(doc, NULL, (const xmlChar *) "ldap_entries", NULL);
+
+ while (ldaplist) {
+ entry = ((struct data_entry *)(ldaplist->data));
+ ldap_debug(conn, 3, "Saving entry: ModTs: %s, uid: %s", entry->modifyTimestamp, entry->uid);
+
+- child = xmlNewChild(doc->children, NULL, "ldapentry", NULL);
+- xmlNewChild(child, NULL, "modifyTimestamp", entry->modifyTimestamp);
+- xmlNewChild(child, NULL, "uid", entry->uid);
++ child = xmlNewChild(doc->children, NULL, (const xmlChar *) "ldapentry", NULL);
++ xmlNewChild(child, NULL, (const xmlChar *) "modifyTimestamp", (const xmlChar *) entry->modifyTimestamp);
++ xmlNewChild(child, NULL, (const xmlChar *) "uid", (const xmlChar *) entry->uid);
+
+ ldaplist = ldaplist->next;
+ }
diff --git a/app-pda/multisync/multisync-0.83_pre20050414-r3.ebuild b/app-pda/multisync/multisync-0.83_pre20050414-r3.ebuild
index c5be4479fe42..3bcd2b96e7e1 100644
--- a/app-pda/multisync/multisync-0.83_pre20050414-r3.ebuild
+++ b/app-pda/multisync/multisync-0.83_pre20050414-r3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/multisync/multisync-0.83_pre20050414-r3.ebuild,v 1.2 2006/02/09 17:07:38 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/multisync/multisync-0.83_pre20050414-r3.ebuild,v 1.3 2006/03/16 17:40:27 sekretarz Exp $
-inherit versionator kde-functions
+inherit versionator kde-functions eutils
CVS_VERSION="${PV/*_pre/}"
S=${WORKDIR}/${PN}
@@ -13,7 +13,7 @@ HOMEPAGE="http://multisync.sourceforge.net/"
SRC_URI="mirror://gentoo/${PN}-${CVS_VERSION}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~x86 ~amd64"
IUSE="evo irmc nokia6600 ldap bluetooth pda kdepim arts kdeenablefinal"
# evo - evolution plugin
# irmc - bluetooth/irmc/irda plugin ( local )
@@ -44,6 +44,13 @@ DEPEND=">=gnome-base/libbonobo-2.2
>=dev-libs/cyrus-sasl-2.1.4 )
nokia6600? ( >=dev-libs/libwbxml-0.9.0 )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-gcc4.patch
+}
+
make_plugin_list() {
local evoversion