summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2010-07-28 06:50:31 +0000
committerAndrey Grozin <grozin@gentoo.org>2010-07-28 06:50:31 +0000
commitc319dd2245477e5c417d1faa93b0b33373eb7d15 (patch)
tree33acab196a5e56bb5f2969b7e51f124f334608df /app-office
parentSync ebuild code with the one in gnome overlay. (diff)
downloadgentoo-2-c319dd2245477e5c417d1faa93b0b33373eb7d15.tar.gz
gentoo-2-c319dd2245477e5c417d1faa93b0b33373eb7d15.tar.bz2
gentoo-2-c319dd2245477e5c417d1faa93b0b33373eb7d15.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'app-office')
-rw-r--r--app-office/texmacs/ChangeLog9
-rw-r--r--app-office/texmacs/files/texmacs-1.0.7.5-strip.patch (renamed from app-office/texmacs/files/texmacs-1.0.7.3-strip.patch)0
-rw-r--r--app-office/texmacs/texmacs-1.0.7.5.ebuild64
3 files changed, 72 insertions, 1 deletions
diff --git a/app-office/texmacs/ChangeLog b/app-office/texmacs/ChangeLog
index bf28a6eddaba..3d21f943bd69 100644
--- a/app-office/texmacs/ChangeLog
+++ b/app-office/texmacs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-office/texmacs
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/ChangeLog,v 1.81 2010/04/13 14:03:44 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/ChangeLog,v 1.82 2010/07/28 06:50:30 grozin Exp $
+
+*texmacs-1.0.7.5 (28 Jul 2010)
+
+ 28 Jul 2010; Andrey Grozin <grozin@gentoo.org>
+ -files/texmacs-1.0.7.3-strip.patch, +texmacs-1.0.7.5.ebuild,
+ +files/texmacs-1.0.7.5-strip.patch:
+ Version bump
*texmacs-1.0.7.4 (13 Apr 2010)
diff --git a/app-office/texmacs/files/texmacs-1.0.7.3-strip.patch b/app-office/texmacs/files/texmacs-1.0.7.5-strip.patch
index b6e660eac900..b6e660eac900 100644
--- a/app-office/texmacs/files/texmacs-1.0.7.3-strip.patch
+++ b/app-office/texmacs/files/texmacs-1.0.7.5-strip.patch
diff --git a/app-office/texmacs/texmacs-1.0.7.5.ebuild b/app-office/texmacs/texmacs-1.0.7.5.ebuild
new file mode 100644
index 000000000000..8f111e8281af
--- /dev/null
+++ b/app-office/texmacs/texmacs-1.0.7.5.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/texmacs-1.0.7.5.ebuild,v 1.1 2010/07/28 06:50:30 grozin Exp $
+EAPI=2
+inherit autotools
+MY_P=${P/tex/TeX}-src
+DESCRIPTION="Wysiwyg text processor with high-quality maths"
+
+SRC_URI="ftp://ftp.texmacs.org/pub/TeXmacs/targz/${MY_P}.tar.gz
+ ftp://ftp.texmacs.org/pub/TeXmacs/targz/TeXmacs-600dpi-fonts.tar.gz"
+
+HOMEPAGE="http://www.texmacs.org/"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="imlib jpeg netpbm -qt4 svg spell"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+
+RDEPEND="dev-scheme/guile[deprecated]
+ virtual/latex-base
+ app-text/ghostscript-gpl
+ media-libs/freetype
+ x11-libs/libXext
+ x11-apps/xmodmap
+ qt4? ( x11-libs/qt-gui:4 )
+ imlib? ( media-libs/imlib2 )
+ jpeg? ( || ( media-gfx/imagemagick media-gfx/jpeg2ps ) )
+ svg? ( || ( media-gfx/inkscape gnome-base/librsvg ) )
+ netpbm? ( media-libs/netpbm )
+ spell? ( || ( >=app-text/ispell-3.2 >=app-text/aspell-0.5 ) )"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use qt4; then
+ ewarn "Qt port is highly experimental"
+ ewarn "If you want a stable TeXmacs, emerge with USE=-qt4"
+ fi
+}
+
+src_prepare() {
+ # don't strip
+ epatch "${FILESDIR}"/${P}-strip.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_with imlib imlib2) \
+ --enable-optimize="${CXXFLAGS}" \
+ $(use_enable qt4 qt)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc TODO || die "dodoc failed"
+ domenu "${FILESDIR}"/TeXmacs.desktop || die "domenu failed"
+
+ # now install the fonts
+ insinto /usr/share/texmf
+ doins -r "${WORKDIR}/fonts" || die "installing fonts failed"
+}