summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2004-04-23 00:28:27 +0000
committerCaleb Tennis <caleb@gentoo.org>2004-04-23 00:28:27 +0000
commit8d7a5e181584fb717b3af2560d785da47ab0ecc5 (patch)
treefa2256b26c08ec7917db7e645a8fa21ea2e1a4ce /app-office
parentRemoved old versions. (Manifest recommit) (diff)
downloadgentoo-2-8d7a5e181584fb717b3af2560d785da47ab0ecc5.tar.gz
gentoo-2-8d7a5e181584fb717b3af2560d785da47ab0ecc5.tar.bz2
gentoo-2-8d7a5e181584fb717b3af2560d785da47ab0ecc5.zip
move python stuff out of global scope
Diffstat (limited to 'app-office')
-rw-r--r--app-office/koffice/ChangeLog6
-rw-r--r--app-office/koffice/koffice-1.2.1-r1.ebuild9
-rw-r--r--app-office/koffice/koffice-1.3.ebuild9
3 files changed, 16 insertions, 8 deletions
diff --git a/app-office/koffice/ChangeLog b/app-office/koffice/ChangeLog
index 0a67999ab5c7..d32600e4ca4b 100644
--- a/app-office/koffice/ChangeLog
+++ b/app-office/koffice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/koffice
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.41 2004/04/20 15:48:26 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.42 2004/04/23 00:28:27 caleb Exp $
+
+ 22 Apr 2004; Caleb Tennis <caleb@gentoo.org> koffice-1.2.1-r1.ebuild,
+ koffice-1.3.ebuild:
+ Move python stuff out of global scope
20 Apr 2004; Martin Holzer <mholzer@gentoo.org> koffice-1.2.1-r1.ebuild:
fixing qa issue with autoconf/automake
diff --git a/app-office/koffice/koffice-1.2.1-r1.ebuild b/app-office/koffice/koffice-1.2.1-r1.ebuild
index f9925b9c90db..2bf2a086af40 100644
--- a/app-office/koffice/koffice-1.2.1-r1.ebuild
+++ b/app-office/koffice/koffice-1.2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.2.1-r1.ebuild,v 1.9 2004/04/20 15:48:26 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.2.1-r1.ebuild,v 1.10 2004/04/23 00:28:27 caleb Exp $
inherit kde-base flag-o-matic
filter-flags "-fomit-frame-pointer"
@@ -21,8 +21,11 @@ DEPEND="$DEPEND
PATCHES="$FILESDIR/${P}-kword-crashes.diff"
-export LIBPYTHON="`python-config --libs`"
-export LIBPYTHON="${LIBPYTHON//-L \/usr\/lib\/python2.2\/config}"
+src_compile() {
+ export LIBPYTHON="`python-config --libs`"
+ export LIBPYTHON="${LIBPYTHON//-L \/usr\/lib\/python2.2\/config}"
+ kde_src_compile
+}
export WANT_AUTOCONF=2.5
export WANT_AUTOMAKE=1.5
diff --git a/app-office/koffice/koffice-1.3.ebuild b/app-office/koffice/koffice-1.3.ebuild
index cacefc51fc64..ab8fa3ed4827 100644
--- a/app-office/koffice/koffice-1.3.ebuild
+++ b/app-office/koffice/koffice-1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.3.ebuild,v 1.5 2004/04/16 01:15:25 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.3.ebuild,v 1.6 2004/04/23 00:28:27 caleb Exp $
inherit kde
# TODO : mysql support
@@ -24,6 +24,7 @@ DEPEND="$DEPEND
>=app-text/wv2-0.1.8
dev-util/pkgconfig"
-export LIBPYTHON="`python-config --libs`"
-#export LIBPYTHON="${LIBPYTHON//-L \/usr\/lib\/python2.2\/config}"
-
+src_compile() {
+ export LIBPYTHON="`python-config --libs`"
+ kde_src_compile
+}