summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Ehmsen <ehmsen@gentoo.org>2006-05-29 18:32:35 +0000
committerMartin Ehmsen <ehmsen@gentoo.org>2006-05-29 18:32:35 +0000
commitd81b73a2cef38a4644965ce0ee4b47b8b9751459 (patch)
treeaca9139a09d802cfbc19b9bd98724152d906b1ba /app-office/texmacs
parentStable on hppa. (diff)
downloadgentoo-2-d81b73a2cef38a4644965ce0ee4b47b8b9751459.tar.gz
gentoo-2-d81b73a2cef38a4644965ce0ee4b47b8b9751459.tar.bz2
gentoo-2-d81b73a2cef38a4644965ce0ee4b47b8b9751459.zip
Fixed gcc-4.1 compilation failure, bug #130708.
(Portage version: 2.1_rc2-r3)
Diffstat (limited to 'app-office/texmacs')
-rw-r--r--app-office/texmacs/ChangeLog6
-rw-r--r--app-office/texmacs/files/texmacs-1.0.6-gcc-4.1.patch107
-rw-r--r--app-office/texmacs/texmacs-1.0.6-r1.ebuild5
3 files changed, 115 insertions, 3 deletions
diff --git a/app-office/texmacs/ChangeLog b/app-office/texmacs/ChangeLog
index 1b89b5fd9293..7d4248c3ade4 100644
--- a/app-office/texmacs/ChangeLog
+++ b/app-office/texmacs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-office/texmacs
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/ChangeLog,v 1.43 2006/05/01 11:07:23 ehmsen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/ChangeLog,v 1.44 2006/05/29 18:32:34 ehmsen Exp $
+
+ 29 May 2006; Martin Ehmsen <ehmsen@gentoo.org>
+ +files/texmacs-1.0.6-gcc-4.1.patch, texmacs-1.0.6-r1.ebuild:
+ Fixed gcc-4.1 compilation failure, bug #130708.
01 May 2006; Martin Ehmsen <ehmsen@gentoo.org> texmacs-1.0.4-r1.ebuild,
texmacs-1.0.5.6.ebuild, texmacs-1.0.6-r1.ebuild:
diff --git a/app-office/texmacs/files/texmacs-1.0.6-gcc-4.1.patch b/app-office/texmacs/files/texmacs-1.0.6-gcc-4.1.patch
new file mode 100644
index 000000000000..7c684b3160dc
--- /dev/null
+++ b/app-office/texmacs/files/texmacs-1.0.6-gcc-4.1.patch
@@ -0,0 +1,107 @@
+--- texmacs-1.0.6.orig/src/Classes/Atomic/parse_string.hpp
++++ texmacs-1.0.6/src/Classes/Atomic/parse_string.hpp
+@@ -48,4 +48,6 @@
+ };
+ CONCRETE_CODE(parse_string);
+
++bool test (parse_string s, string what);
++
+ #endif // defined PARSE_STRING_H
+only in patch2:
+unchanged:
+--- texmacs-1.0.6.orig/src/System/Classes/url.hpp
++++ texmacs-1.0.6/src/System/Classes/url.hpp
+@@ -42,6 +42,8 @@
+ };
+ CONCRETE_CODE(url);
+
++inline url as_url (tree t);
++
+ ostream& operator << (ostream& out, url u);
+ string as_string (url u, int type= URL_SYSTEM);
+
+only in patch2:
+unchanged:
+--- texmacs-1.0.6.orig/src/Typeset/boxes.hpp
++++ texmacs-1.0.6/src/Typeset/boxes.hpp
+@@ -252,6 +252,8 @@
+ };
+ ABSTRACT_NULL_CODE(box);
+
++void make_eps (url dest, ::display dis, box b, int dpi);
++
+ extern int box_count;
+ inline box_rep::box_rep (path ip2):
+ x0(0), y0(0), x1(0), y1(0), x2(0), y2(0), x3(0), y3(0), x4(0), y4(0),
+only in patch2:
+unchanged:
+--- texmacs-1.0.6.orig/src/Typeset/env.hpp
++++ texmacs-1.0.6/src/Typeset/env.hpp
+@@ -433,5 +433,6 @@
+ tree texmacs_exec (edit_env env, tree cmd);
+ void extract_format (tree fm, tree* r, int n);
+ tree load_inclusion (url u); // implemented in tm_file.cpp
++ostream& operator << (ostream& out, edit_env env);
+
+ #endif // defined ENV_H
+only in patch2:
+unchanged:
+--- texmacs-1.0.6.orig/src/Typeset/Bridge/bridge.hpp
++++ texmacs-1.0.6/src/Typeset/Bridge/bridge.hpp
+@@ -73,6 +73,7 @@
+ };
+ ABSTRACT_NULL_CODE(bridge);
+
++bridge make_bridge (typesetter ttt, tree st, path ip);
+ ostream& operator << (ostream& out, bridge br);
+ extern bridge nil_bridge;
+ tree substitute (tree t, path p, tree u);
+only in patch2:
+unchanged:
+--- texmacs-1.0.6.orig/src/Typeset/Concat/concater.hpp
++++ texmacs-1.0.6/src/Typeset/Concat/concater.hpp
+@@ -169,6 +169,9 @@
+ friend array<line_item> typeset_marker (edit_env env, path ip);
+ };
+
++array<line_item> typeset_concat (edit_env env, tree t, path ip);
++array<line_item> typeset_marker (edit_env env, path ip);
++
+ typedef concater_rep* concater;
+
+ #endif // defined CONCATER_H
+only in patch2:
+unchanged:
+--- texmacs-1.0.6.orig/src/Window/ps_device.hpp
++++ texmacs-1.0.6/src/Window/ps_device.hpp
+@@ -102,4 +102,8 @@
+ virtual void apply_shadow (SI x1, SI y1, SI x2, SI y2) = 0;
+ };
+
++void abs_round (SI& l);
++void abs_round (SI& x, SI& y);
++void abs_outer_round (SI& x1, SI& y1, SI& x2, SI& y2);
++
+ #endif // defined PS_DEVICE_H
+only in patch2:
+unchanged:
+--- texmacs-1.0.6.orig/src/Window/Widget/Basic/basic_widget.cpp
++++ texmacs-1.0.6/src/Window/Widget/Basic/basic_widget.cpp
+@@ -259,7 +259,7 @@
+ test_window_attached (event ev, widget w) {
+ if (!w->attached ()) {
+ cerr << "\n" << HRULE << "\n";
+- cerr << ev << " was sent to\n" << w;
++ cerr << (tree)ev << " was sent to\n" << w;
+ cerr << HRULE << "\n";
+ fatal_error ("widget was not yet attached to window",
+ "basic_widget::handle", "basic_diwget.cpp");
+@@ -268,7 +268,7 @@
+
+ bool
+ basic_widget_rep::handle (event ev) {
+- if (DEBUG_EVENTS) cout << "TeXmacs] " << ev << "\n";
++ if (DEBUG_EVENTS) cout << "TeXmacs] " << (tree)ev << "\n";
+ // " ---> " << widget(this) << "\n";
+ if (attached ()) win->set_origin (ox, oy);
+ switch (ev->type) {
diff --git a/app-office/texmacs/texmacs-1.0.6-r1.ebuild b/app-office/texmacs/texmacs-1.0.6-r1.ebuild
index e883a3d3077a..7ed23fd81229 100644
--- a/app-office/texmacs/texmacs-1.0.6-r1.ebuild
+++ b/app-office/texmacs/texmacs-1.0.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/texmacs-1.0.6-r1.ebuild,v 1.2 2006/05/01 11:07:23 ehmsen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/texmacs/texmacs-1.0.6-r1.ebuild,v 1.3 2006/05/29 18:32:34 ehmsen Exp $
# although flag-o-matic functions in portage, we should inherit it
inherit flag-o-matic eutils
@@ -39,7 +39,8 @@ src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}/${P}-maxima-5.9.3.patch" || die "patch failed"
+ epatch "${FILESDIR}/${P}-maxima-5.9.3.patch" || die "maxima patch failed"
+ epatch "${FILESDIR}/${P}-gcc-4.1.patch" || die "gcc-4.1 patch failed"
}
src_compile() {