summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2008-06-11 22:04:02 +0000
committerChristian Faulhammer <opfer@gentoo.org>2008-06-11 22:04:02 +0000
commit1a93d313c7136fb4313b5ffb5e01f44dcd2b128b (patch)
treeb489efe8d8499e25612474fed298337ff8fb46da /app-misc
parentstable x86, bug 225899 (diff)
downloadgentoo-2-1a93d313c7136fb4313b5ffb5e01f44dcd2b128b.tar.gz
gentoo-2-1a93d313c7136fb4313b5ffb5e01f44dcd2b128b.tar.bz2
gentoo-2-1a93d313c7136fb4313b5ffb5e01f44dcd2b128b.zip
clean up
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/devtodo/ChangeLog8
-rw-r--r--app-misc/devtodo/devtodo-0.1.19-r2.ebuild52
-rw-r--r--app-misc/devtodo/files/devtodo-0.1.18-gcc4.diff22
-rw-r--r--app-misc/devtodo/files/devtodo-0.1.19-fix-multiline-segv.diff12
-rw-r--r--app-misc/devtodo/files/devtodo-0.1.19-r2-gentoo.diff146
5 files changed, 7 insertions, 233 deletions
diff --git a/app-misc/devtodo/ChangeLog b/app-misc/devtodo/ChangeLog
index 38184dd61a57..8fbb95ed7bd2 100644
--- a/app-misc/devtodo/ChangeLog
+++ b/app-misc/devtodo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/devtodo
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/ChangeLog,v 1.79 2008/04/21 19:23:10 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/ChangeLog,v 1.80 2008/06/11 22:04:02 opfer Exp $
+
+ 11 Jun 2008; Christian Faulhammer <opfer@gentoo.org>
+ -files/devtodo-0.1.18-gcc4.diff,
+ -files/devtodo-0.1.19-fix-multiline-segv.diff,
+ -files/devtodo-0.1.19-r2-gentoo.diff, -devtodo-0.1.19-r2.ebuild:
+ clean up
21 Apr 2008; Markus Ullmann <jokey@gentoo.org>
+files/devtodo-0.1.20-gcc43.patch, devtodo-0.1.20.ebuild:
diff --git a/app-misc/devtodo/devtodo-0.1.19-r2.ebuild b/app-misc/devtodo/devtodo-0.1.19-r2.ebuild
deleted file mode 100644
index 75af0355d05e..000000000000
--- a/app-misc/devtodo/devtodo-0.1.19-r2.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/devtodo/devtodo-0.1.19-r2.ebuild,v 1.1 2007/04/07 15:21:40 jokey Exp $
-
-inherit eutils bash-completion flag-o-matic
-
-DESCRIPTION="A nice command line todo list for developers"
-HOMEPAGE="http://swapoff.org/DevTodo"
-SRC_URI="http://swapoff.org/files/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
-IUSE=""
-
-RDEPEND=">=sys-libs/ncurses-5.2
- >=sys-libs/readline-4.1"
-DEPEND="${RDEPEND}"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-0.1.18-gcc4.diff
- epatch ${FILESDIR}/${P}-r2-gentoo.diff
- epatch ${FILESDIR}/${P}-fix-multiline-segv.diff
-}
-
-src_compile() {
- einfo "Running autoreconf"
- autoreconf -f -i || die "autoreconf failed"
- replace-flags -O[23] -O1
- econf --sysconfdir=/etc/devtodo || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR=${D} install || die "make install failed"
- dodoc AUTHORS ChangeLog QuickStart README doc/scripts.sh \
- doc/scripts.tcsh doc/todorc.example || die "dodoc failed"
-
- dobashcompletion contrib/${PN}.bash-completion ${PN}
- rm contrib/${PN}.bash-completion
- docinto contrib
- dodoc contrib/*
-}
-
-pkg_postinst() {
- echo
- elog "Because of a conflict with app-misc/tdl, the tdl symbolic link"
- elog "and manual page have been removed."
- bash-completion_pkg_postinst
-}
diff --git a/app-misc/devtodo/files/devtodo-0.1.18-gcc4.diff b/app-misc/devtodo/files/devtodo-0.1.18-gcc4.diff
deleted file mode 100644
index e0f31f192f1d..000000000000
--- a/app-misc/devtodo/files/devtodo-0.1.18-gcc4.diff
+++ /dev/null
@@ -1,22 +0,0 @@
---- src/Todo.h.orig 2005-06-06 12:15:58.000000000 -0400
-+++ src/Todo.h 2005-06-06 12:13:41.000000000 -0400
-@@ -14,6 +14,8 @@
- 01/02/01 Initial creation
- */
-
-+class TodoDB;
-+
- class Todo {
- public :
- friend class TodoDB;
---- src/TodoDB.h 2006-03-17 16:49:41.000000000 -0500
-+++ src/TodoDB.h 2006-03-17 16:50:12.000000000 -0500
-@@ -108,7 +108,7 @@
- void initColour();
- void initColourPost();
- Todo::Priority getPriority(string current = "");
-- int TodoDB::markDone(Todo &todo);
-+ int markDone(Todo &todo);
-
- void formatItem(ostream &out, int depth, Todo const &item, string const &format);
-
diff --git a/app-misc/devtodo/files/devtodo-0.1.19-fix-multiline-segv.diff b/app-misc/devtodo/files/devtodo-0.1.19-fix-multiline-segv.diff
deleted file mode 100644
index 5eb38ea7f0be..000000000000
--- a/app-misc/devtodo/files/devtodo-0.1.19-fix-multiline-segv.diff
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --exclude='*~' --exclude='.*' -I '$Id:' -urN devtodo-0.1.19.orig/util/XML.cc devtodo-0.1.19/util/XML.cc
---- devtodo-0.1.19.orig/util/XML.cc 2005-10-29 11:02:17.000000000 -0400
-+++ devtodo-0.1.19/util/XML.cc 2005-10-29 11:03:39.000000000 -0400
-@@ -51,7 +51,7 @@
- "*[[:space:]]*(/?)>");
- xmlScan.addPattern(XmlEnd, "</[a-zA-Z0-9_-]+>");
- xmlScan.addPattern(XmlDataBegin, "<!DATA[[:space:]]*\\[\\[");
-- xmlScan.addPattern(XmlContent, "([^<]|[\n\r])+");
-+ xmlScan.addPattern(XmlContent, "([\n\r]|[^<])+");
-
- commentScan.addPattern(CommentEnd, "-->[[:space:]]*");
- commentScan.addPattern(CommentBody, "[\n\r]|.");
diff --git a/app-misc/devtodo/files/devtodo-0.1.19-r2-gentoo.diff b/app-misc/devtodo/files/devtodo-0.1.19-r2-gentoo.diff
deleted file mode 100644
index 7c55f0e7f031..000000000000
--- a/app-misc/devtodo/files/devtodo-0.1.19-r2-gentoo.diff
+++ /dev/null
@@ -1,146 +0,0 @@
-diff -urN devtodo-0.1.18.orig/acconfig.h devtodo-0.1.18/acconfig.h
---- devtodo-0.1.18.orig/acconfig.h 2004-12-17 10:21:09.168345388 -0500
-+++ devtodo-0.1.18/acconfig.h 1969-12-31 19:00:00.000000000 -0500
-@@ -1,6 +0,0 @@
--/* System configuration directory */
--#undef SYSCONFDIR
--
--/* Use termcap to get terminal width */
--#undef USETERMCAP
--@TOP@
-diff -urN devtodo-0.1.18.orig/configure.in devtodo-0.1.18/configure.in
---- devtodo-0.1.18.orig/configure.in 2004-12-17 10:21:09.166345721 -0500
-+++ devtodo-0.1.18/configure.in 2004-12-17 10:21:34.049210408 -0500
-@@ -25,7 +25,7 @@
- # Don't use termcap to obtain window size
- AC_ARG_WITH(termcap, [ --without-termcap don't use termcap to obtain terminal width])
- if test "${with_termcap}_" = _ -o "${with_termcap}_" = yes; then
-- AC_DEFINE(USETERMCAP)
-+ AC_DEFINE(USETERMCAP, [], [Use termcap?])
- fi
-
- # Check for various headers and functions - although I'm not doing anything
-@@ -79,7 +79,7 @@
- AC_SUBST(READLINE_LIBS)
-
- SYSCONFDIR="`eval echo $sysconfdir`"
--AC_DEFINE_UNQUOTED(SYSCONFDIR, "$SYSCONFDIR")
-+AC_DEFINE_UNQUOTED(SYSCONFDIR, "$SYSCONFDIR", [System configuration directory])
- AC_SUBST(SYSCONFDIR)
-
- AC_CHECK_PROG(HAVE_CRASH_CONFIG, crash-config, yes)
-diff -urN devtodo-0.1.18.orig/doc/devtodo.1.in devtodo-0.1.18/doc/devtodo.1.in
---- devtodo-0.1.18.orig/doc/devtodo.1.in 2004-12-17 10:21:09.135350872 -0500
-+++ devtodo-0.1.18/doc/devtodo.1.in 2004-12-17 10:21:34.050210242 -0500
-@@ -20,9 +20,6 @@
- .TP
- \fBtdd \fI<indices>\fP\fP
- Mark the specified items as being done.
--.TP
--\fBtdl [\-g \fI<index>\fP] \fI<database>\fP\fP
--Link the specified devtodo database into the current one, optionally grafting it as a child of the specified index.
- .SH "DESCRIPTION"
- .LP
- \fBtodo\fP is a program aimed specifically at programmers (but usable by anybody at the terminal) to aid in day\-to\-day development.
-@@ -372,6 +369,10 @@
- .TP
- \fB~/.todorc\fR
- User-specific options are specified in this file. Please refer to the section \fBTODORC\fR for more information.
-+.SH "BUGS"
-+.LP
-+Because of a conflict with app-misc/tdl, the tdl symbolic link and the tdl manual page have been removed.
-+See \fIhttp://bugs.gentoo.org/show_bug.cgi?id=55371\fR for more information.
- .SH "AUTHORS"
- .LP
- Alec Thomas \fI<alec@swapoff.org>\fR
-diff -urN devtodo-0.1.18.orig/doc/Makefile.am devtodo-0.1.18/doc/Makefile.am
---- devtodo-0.1.18.orig/doc/Makefile.am 2004-12-17 10:21:09.135350872 -0500
-+++ devtodo-0.1.18/doc/Makefile.am 2004-12-17 10:21:34.050210242 -0500
-@@ -1,5 +1,5 @@
- man_MANS=devtodo.1
--manlinks=tda tdr tdd tde tdl todo
-+manlinks=tda tdr tdd tde todo
-
- install-data-local:
- mkdir -p $(DESTDIR)$(mandir)/man1
-diff -urN devtodo-0.1.18.orig/src/Makefile.am devtodo-0.1.18/src/Makefile.am
---- devtodo-0.1.18.orig/src/Makefile.am 2004-12-17 10:21:09.154347715 -0500
-+++ devtodo-0.1.18/src/Makefile.am 2004-12-17 10:21:34.053209744 -0500
-@@ -1,18 +1,12 @@
- bin_PROGRAMS=devtodo
- devtodo_SOURCES=Todo.cc Todo.h TodoDB.cc TodoDB.h support.cc support.h \
- main.cc todoterm.cc todoterm.h Loaders.cc Loaders.h todorl.h
--binlinks=tda tdr tdd tdl tde todo
-+binlinks=tda tdr tdd tde todo
-
- devtodo_LDADD=../util/libutil.la
- INCLUDES=-I../util
- LIBS=@READLINE_LIBS@
-
--if DEBUG
--CPPFLAGS=-g
--else
--CPPFLAGS+=-DNDEBUG
--endif
--
- install-exec-hook:
- cd $(DESTDIR)$(bindir); for i in $(binlinks); do $(LN_S) -f devtodo $$i; done
-
-diff -urN devtodo-0.1.18.orig/src/TodoDB.cc devtodo-0.1.18/src/TodoDB.cc
---- devtodo-0.1.18.orig/src/TodoDB.cc 2004-12-17 10:21:09.136350706 -0500
-+++ devtodo-0.1.18/src/TodoDB.cc 2004-12-17 10:21:34.054209577 -0500
-@@ -949,7 +948,11 @@
- if (out.bad())
- throw exception("couldn't open TODO for generation");
-
-- if (titleText != "") wraptext(out, titleText, 0, options.columns);
-+ if (titleText != "") {
-+ wraptext(out, titleText, 0, options.columns);
-+ out << endl << endl;
-+ }
-+
- if (options.verbose > 1)
- cout << "todo: generating using format '" << options.format["verbose-generated"] << "'" << endl;
- filterView();
-diff -urN devtodo-0.1.18.orig/util/c_regex.h devtodo-0.1.18/util/c_regex.h
---- devtodo-0.1.18.orig/util/c_regex.h 2004-12-17 10:21:09.157347216 -0500
-+++ devtodo-0.1.18/util/c_regex.h 2004-12-17 10:25:41.026169344 -0500
-@@ -533,7 +533,10 @@
- /* For now unconditionally define __restrict_arr to expand to nothing.
- Ideally we would have a test for the compiler which allows defining
- it to restrict. */
--#define __restrict_arr
-+#ifdef __restrict_arr
-+# undef __restrict_arr
-+# define __restrict_arr
-+#endif
-
- /* POSIX compatibility. */
- extern int regcomp _RE_ARGS ((regex_t *__restrict __preg,
---- devtodo-0.1.19/contrib/devtodo.bash-completion {cset 9b4d9f02-fdb7-4641-b07f-7359b794d6b0}
-+++ devtodo-0.1.19/contrib/devtodo.bash-completion {local clone}
-@@ -35,6 +35,6 @@ _devtodo() {
- ;;
- esac
- }
--complete -o filenames -F _devtodo devtodo todo tda tde tdr tdd tdl
-+complete -o filenames -F _devtodo devtodo todo tda tde tdr tdd
-
- # vim: set ft=sh tw=80 sw=4 et :
---- devtodo-0.1.19/src/support.cc {cset 5f5bd9cb-18fb-4046-bff5-4f3dbd781e47}
-+++ devtodo-0.1.19/src/support.cc {local clone}
-@@ -289,11 +289,10 @@ enum { Help = -100, Remove, Version, Tit
- << "Where <arguments> can be any of the following:" << endl;
- args.displayHelp(cout, options.columns);
- cout << endl
-- << "In addition, there are five convenience symlinks. These are 'tda', 'tdr'," << endl
-- << "'tdd', 'tde', and 'tdl'. For 'tde', 'tdd' and 'tdr' supply an index to edit," << endl
-+ << "In addition, there are four convenience symlinks. These are 'tda', 'tdr'," << endl
-+ << "'tdd', and 'tde'. For 'tde', 'tdd' and 'tdr' supply an index to edit," << endl
- << "mark done and remove respectively. For 'tda' supply the text of the todo item" << endl
-- << "item and optionally the priority. For 'tdl' supply the path to another todo" << endl
-- << "file to link in to the current todo file." << endl
-+ << "item and optionally the priority." << endl
- << "eg. tde 1" << endl;
- exit(0);
- break;