summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-10-23 06:12:17 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-10-23 06:12:17 +0000
commitea5b9fd033061f8d516a23445e94f87c6257918e (patch)
treef2fc0a5dde2a494ce50619ddac8bf5b60c523f7e /app-misc/dnetc
parentChangeLog (diff)
downloadgentoo-2-ea5b9fd033061f8d516a23445e94f87c6257918e.tar.gz
gentoo-2-ea5b9fd033061f8d516a23445e94f87c6257918e.tar.bz2
gentoo-2-ea5b9fd033061f8d516a23445e94f87c6257918e.zip
Refactor SRC_URI handling slightly. Add latest sparc build.
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/dnetc')
-rw-r--r--app-misc/dnetc/ChangeLog8
-rw-r--r--app-misc/dnetc/dnetc-2.9107.516.ebuild94
-rw-r--r--app-misc/dnetc/dnetc-2.9108.517.ebuild7
-rw-r--r--app-misc/dnetc/dnetc-2.9109.518.ebuild7
4 files changed, 109 insertions, 7 deletions
diff --git a/app-misc/dnetc/ChangeLog b/app-misc/dnetc/ChangeLog
index e6306e7cdb15..7079d208b484 100644
--- a/app-misc/dnetc/ChangeLog
+++ b/app-misc/dnetc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/dnetc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/ChangeLog,v 1.61 2011/10/23 06:02:32 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/ChangeLog,v 1.62 2011/10/23 06:12:17 robbat2 Exp $
+
+*dnetc-2.9107.516 (23 Oct 2011)
+
+ 23 Oct 2011; Robin H. Johnson <robbat2@gentoo.org> +dnetc-2.9107.516.ebuild,
+ dnetc-2.9108.517.ebuild, dnetc-2.9109.518.ebuild:
+ Refactor SRC_URI handling slightly. Add latest sparc build.
*dnetc-2.9109.518 (23 Oct 2011)
*dnetc-2.9108.517 (23 Oct 2011)
diff --git a/app-misc/dnetc/dnetc-2.9107.516.ebuild b/app-misc/dnetc/dnetc-2.9107.516.ebuild
new file mode 100644
index 000000000000..c123ddbfa54e
--- /dev/null
+++ b/app-misc/dnetc/dnetc-2.9107.516.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/dnetc-2.9107.516.ebuild,v 1.1 2011/10/23 06:12:17 robbat2 Exp $
+
+EAPI=2
+inherit eutils
+
+MAJ_PV=${PV:0:6}
+MIN_PV=${PV:7:9}
+
+DESCRIPTION="distributed.net client"
+HOMEPAGE="http://www.distributed.net"
+#SRC_URI_x86="x86? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-x86-elf-uclibc.tar.gz )"
+#SRC_URI_amd64="amd64? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-amd64.tar.gz )"
+#SRC_URI_ppc="ppc? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-ppc-uclibc.tar.gz )"
+SRC_URI_sparc="sparc? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-sparc-v7.tar.gz )"
+SRC_URI="${SRC_URI_amd64} ${SRC_URI_ppc} ${SRC_URI_x86} ${SRC_URI_sparc}"
+
+LICENSE="distributed.net"
+SLOT="0"
+KEYWORDS="~sparc" # x86,amd64,ppc not available for this version
+IUSE=""
+RESTRICT="mirror"
+
+DEPEND=""
+RDEPEND="net-dns/bind-tools"
+
+QA_PRESTRIPPED="opt/distributed.net/dnetc"
+
+S=${WORKDIR}/dnetc
+
+src_prepare() {
+ binname=""
+ if use amd64; then
+ binname=dnetc${MIN_PV}-linux-amd64
+ elif use x86; then
+ binname=dnetc${MIN_PV}-linux-x86-elf-uclibc
+ elif use ppc; then
+ binname=dnetc${MIN_PV}-linux-ppc-elf-uclibc
+ fi
+ [[ -z "${binname}" ]] && die "Name of dnetc binary for this platform undefined"
+ mv "${binname}" dnetc || die "$binname binary is missing"
+}
+
+src_install() {
+ exeinto /opt/distributed.net
+ doexe dnetc
+
+ doman dnetc.1
+ dodoc docs/CHANGES.txt docs/dnetc.txt docs/readme.*
+
+ newinitd "${FILESDIR}"/dnetc.initd dnetc
+ newconfd "${FILESDIR}"/dnetc.confd dnetc
+
+ keepdir /var/spool/dnetc
+}
+
+pkg_preinst() {
+ if [ -e /opt/distributed.net/dnetc ] && [ -e /etc/init.d/dnetc ]; then
+ einfo "flushing old buffers"
+ source /etc/conf.d/dnetc
+
+ if [ -e /opt/distributed.net/dnetc.ini ]; then
+ # use ini file
+ /opt/distributed.net/dnetc -quiet -ini /opt/distributed.net/dnetc.ini -flush
+ elif [ ! -e /opt/distributed.net/dnetc.ini ] && [ ! -z ${EMAIL} ]; then
+ # email adress from config
+ /opt/distributed.net/dnetc -quiet -flush -e ${EMAIL}
+ fi
+
+ einfo "removing old buffer files"
+ rm -f /opt/distributed.net/buff*
+ fi
+
+ enewgroup dnetc
+ enewuser dnetc -1 -1 /opt/distributed.net dnetc
+}
+
+pkg_postinst() {
+ chown -Rf dnetc:dnetc /opt/distributed.net
+ chmod 0555 /opt/distributed.net/dnetc
+
+ elog "To run distributed.net client in the background at boot:"
+ elog " rc-update add dnetc default"
+ elog ""
+ elog "Either configure your email address in /etc/conf.d/dnetc"
+ elog "or create the configuration file /opt/distributed.net/dnetc.ini"
+}
+
+pkg_postrm() {
+ if [ -d /opt/distributed.net ]; then
+ elog "All files has not been removed from /opt/distributed.net"
+ fi
+}
diff --git a/app-misc/dnetc/dnetc-2.9108.517.ebuild b/app-misc/dnetc/dnetc-2.9108.517.ebuild
index cb3cadcdc0fd..79a9500ac770 100644
--- a/app-misc/dnetc/dnetc-2.9108.517.ebuild
+++ b/app-misc/dnetc/dnetc-2.9108.517.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/dnetc-2.9108.517.ebuild,v 1.1 2011/10/23 06:02:32 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/dnetc-2.9108.517.ebuild,v 1.2 2011/10/23 06:12:17 robbat2 Exp $
EAPI=2
inherit eutils
@@ -12,8 +12,9 @@ DESCRIPTION="distributed.net client"
HOMEPAGE="http://www.distributed.net"
SRC_URI_x86="x86? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-x86-elf-uclibc.tar.gz )"
SRC_URI_amd64="amd64? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-amd64.tar.gz )"
-SRC_URI_ppc="ppc? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-ppc-uclibc.tar.gz )"
-SRC_URI="${SRC_URI_amd64} ${SRC_URI_x86}"
+#SRC_URI_ppc="ppc? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-ppc-uclibc.tar.gz )"
+#SRC_URI_sparc="sparc? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-sparc-v7.tar.gz )"
+SRC_URI="${SRC_URI_amd64} ${SRC_URI_ppc} ${SRC_URI_x86} ${SRC_URI_sparc}"
LICENSE="distributed.net"
SLOT="0"
diff --git a/app-misc/dnetc/dnetc-2.9109.518.ebuild b/app-misc/dnetc/dnetc-2.9109.518.ebuild
index b60fa3f03b32..eead468d5321 100644
--- a/app-misc/dnetc/dnetc-2.9109.518.ebuild
+++ b/app-misc/dnetc/dnetc-2.9109.518.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/dnetc-2.9109.518.ebuild,v 1.1 2011/10/23 06:02:32 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/dnetc/dnetc-2.9109.518.ebuild,v 1.2 2011/10/23 06:12:17 robbat2 Exp $
EAPI=2
inherit eutils
@@ -10,10 +10,11 @@ MIN_PV=${PV:7:9}
DESCRIPTION="distributed.net client"
HOMEPAGE="http://www.distributed.net"
-SRC_URI_x86="x86? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-x86-elf-uclibc.tar.gz )"
+#SRC_URI_x86="x86? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-x86-elf-uclibc.tar.gz )"
SRC_URI_amd64="amd64? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-amd64.tar.gz )"
SRC_URI_ppc="ppc? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-ppc-uclibc.tar.gz )"
-SRC_URI="${SRC_URI_amd64} ${SRC_URI_ppc}"
+#SRC_URI_sparc="sparc? ( http://http.distributed.net/pub/dcti/v${MAJ_PV}/dnetc${MIN_PV}-linux-sparc-v7.tar.gz )"
+SRC_URI="${SRC_URI_amd64} ${SRC_URI_ppc} ${SRC_URI_x86} ${SRC_URI_sparc}"
LICENSE="distributed.net"
SLOT="0"