summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-06-24 05:49:36 +0000
committerJeroen Roovers <jer@gentoo.org>2011-06-24 05:49:36 +0000
commit520876b3167b144b3e8e1ceab802d4ae03a87182 (patch)
tree1a905d4051ed04e25f6ca0e03596c86f016a1ea2 /app-misc/btail
parentRemove old versions. (diff)
downloadgentoo-2-520876b3167b144b3e8e1ceab802d4ae03a87182.tar.gz
gentoo-2-520876b3167b144b3e8e1ceab802d4ae03a87182.tar.bz2
gentoo-2-520876b3167b144b3e8e1ceab802d4ae03a87182.zip
Version bump. Clean up ebuild. Fix one compiler warning.
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/btail')
-rw-r--r--app-misc/btail/ChangeLog9
-rw-r--r--app-misc/btail/btail-0.3.ebuild41
2 files changed, 48 insertions, 2 deletions
diff --git a/app-misc/btail/ChangeLog b/app-misc/btail/ChangeLog
index 331c195082cb..8818794e597e 100644
--- a/app-misc/btail/ChangeLog
+++ b/app-misc/btail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/btail
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/btail/ChangeLog,v 1.4 2008/12/30 19:27:36 angelos Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/btail/ChangeLog,v 1.5 2011/06/24 05:49:36 jer Exp $
+
+*btail-0.3 (24 Jun 2011)
+
+ 24 Jun 2011; Jeroen Roovers <jer@gentoo.org> +btail-0.3.ebuild:
+ Version bump. Clean up ebuild. Fix one compiler warning.
30 Dec 2008; Christoph Mende <angelos@gentoo.org> btail-0.2.ebuild:
QA: Respect CC/CXX (bug 243612) and CFLAGS/LDFLAGS (bug 243616)
diff --git a/app-misc/btail/btail-0.3.ebuild b/app-misc/btail/btail-0.3.ebuild
new file mode 100644
index 000000000000..edc51f1d6932
--- /dev/null
+++ b/app-misc/btail/btail-0.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/btail/btail-0.3.ebuild,v 1.1 2011/06/24 05:49:36 jer Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Bayesian logfile filter"
+HOMEPAGE="http://www.vanheusden.com/btail/"
+SRC_URI="${HOMEPAGE}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/gdbm"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i Makefile \
+ -e '/^LDFLAGS/s:=:+=:g' \
+ -e '/$(CC)/s:-Wall:$(CFLAGS) &:g' \
+ || die
+ sed -i conf.cpp \
+ -e '/Configline/s:):, line):g' \
+ || die
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ CC="$(tc-getCC)" \
+ CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ dobin blearn btail
+ dodoc readme.txt btail.conf license.txt
+}