summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda XU <heroxbd@gentoo.org>2013-09-16 10:42:49 +0000
committerBenda XU <heroxbd@gentoo.org>2013-09-16 10:42:49 +0000
commit8f11c4d042b079513d05cd1ddf19c78cfb8e7c95 (patch)
treee12e62ea780ee01c4b83a5e4484f64fcd398d05a /app-i18n
parentkeyword ~arm (diff)
downloadgentoo-2-8f11c4d042b079513d05cd1ddf19c78cfb8e7c95.tar.gz
gentoo-2-8f11c4d042b079513d05cd1ddf19c78cfb8e7c95.tar.bz2
gentoo-2-8f11c4d042b079513d05cd1ddf19c78cfb8e7c95.zip
add gtk3 support for app-i18n/scim-anthy-1.2.7, patch from debian. app-i18n/scim-anthy-1.3.1 seems to be unmaintained upstream, is older than 1.2.7 and is masked in Gentoo, therefore ignored. bug 482990
(Portage version: 2.2.0/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-i18n')
-rw-r--r--app-i18n/scim-anthy/ChangeLog12
-rw-r--r--app-i18n/scim-anthy/metadata.xml5
-rw-r--r--app-i18n/scim-anthy/scim-anthy-1.2.7-r1.ebuild46
-rw-r--r--app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild4
4 files changed, 63 insertions, 4 deletions
diff --git a/app-i18n/scim-anthy/ChangeLog b/app-i18n/scim-anthy/ChangeLog
index bc6d03992420..ce38ea531e84 100644
--- a/app-i18n/scim-anthy/ChangeLog
+++ b/app-i18n/scim-anthy/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-i18n/scim-anthy
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/ChangeLog,v 1.63 2012/09/26 03:23:09 naota Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/ChangeLog,v 1.64 2013/09/16 10:42:49 heroxbd Exp $
+
+*scim-anthy-1.2.7-r1 (16 Sep 2013)
+
+ 16 Sep 2013; Benda Xu <heroxbd@gentoo.org> +scim-anthy-1.2.7-r1.ebuild,
+ metadata.xml, scim-anthy-1.2.7.ebuild:
+ add gtk3 support for app-i18n/scim-anthy-1.2.7, patch from debian. app-i18n
+ /scim-anthy-1.3.1 seems to be unmaintained upstream, is older than 1.2.7 and
+ is masked in Gentoo, therefore ignored. bug 482990
26 Sep 2012; <naota@gentoo.org> scim-anthy-1.2.6.ebuild,
scim-anthy-1.2.7.ebuild, scim-anthy-1.3.1.ebuild:
diff --git a/app-i18n/scim-anthy/metadata.xml b/app-i18n/scim-anthy/metadata.xml
index 2d5852c16c60..8df5e6c79ef7 100644
--- a/app-i18n/scim-anthy/metadata.xml
+++ b/app-i18n/scim-anthy/metadata.xml
@@ -2,4 +2,9 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>cjk</herd>
+<use>
+ <flag name='kasumi'>Use Anthy dictionary maintenance tool
+ (<pkg>app-dicts/kasumi</pkg>)</flag>
+ <flag name='gtk3'>Enable support for <pkg>x11-libs/gtk+</pkg>:3</flag>
+</use>
</pkgmetadata>
diff --git a/app-i18n/scim-anthy/scim-anthy-1.2.7-r1.ebuild b/app-i18n/scim-anthy/scim-anthy-1.2.7-r1.ebuild
new file mode 100644
index 000000000000..738187b53334
--- /dev/null
+++ b/app-i18n/scim-anthy/scim-anthy-1.2.7-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/scim-anthy-1.2.7-r1.ebuild,v 1.1 2013/09/16 10:42:49 heroxbd Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Japanese input method Anthy IMEngine for SCIM"
+HOMEPAGE="http://scim-imengine.sourceforge.jp/index.cgi?cmd=view;name=SCIMAnthy"
+SRC_URI="mirror://sourceforge.jp/scim-imengine/37309/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="+gtk3 nls kasumi"
+
+DEPEND=">=app-i18n/scim-1.2[gtk3=]
+ >=app-i18n/anthy-5900
+ nls? ( virtual/libintl )
+ gtk3? ( x11-libs/gtk+:3 )"
+RDEPEND="${DEPEND}
+ kasumi? ( app-dicts/kasumi )"
+DEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.7-no-rpath.patch
+
+ use gtk3 && epatch "${FILESDIR}"/${PN}-1.2.7-gtk3.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ --disable-static \
+ --disable-dependency-tracking
+}
+
+src_install() {
+ default
+ dodoc AUTHORS ChangeLog NEWS README
+}
diff --git a/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild b/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild
index 6b627769c94f..1101088dd12e 100644
--- a/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild
+++ b/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild,v 1.5 2012/09/26 03:23:09 naota Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/scim-anthy/scim-anthy-1.2.7.ebuild,v 1.6 2013/09/16 10:42:49 heroxbd Exp $
EAPI="2"