summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-03-08 18:20:32 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-03-08 18:20:32 +0000
commit4a519a976a651c42cf7655e23767475075dd293d (patch)
tree34f5448bf7180cd405302c7ab8c1fa47c24c3e49 /app-emulation
parentRestore UI parts in the ebuild. (diff)
downloadgentoo-2-4a519a976a651c42cf7655e23767475075dd293d.tar.gz
gentoo-2-4a519a976a651c42cf7655e23767475075dd293d.tar.bz2
gentoo-2-4a519a976a651c42cf7655e23767475075dd293d.zip
Remove the backslash gluing which was causing odd spacing. Make KVM optional in the kernel for mgorny.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu-kvm/ChangeLog6
-rw-r--r--app-emulation/qemu-kvm/qemu-kvm-1.0-r3.ebuild26
2 files changed, 18 insertions, 14 deletions
diff --git a/app-emulation/qemu-kvm/ChangeLog b/app-emulation/qemu-kvm/ChangeLog
index b2ac0826322f..cd70f2c61880 100644
--- a/app-emulation/qemu-kvm/ChangeLog
+++ b/app-emulation/qemu-kvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/qemu-kvm
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/ChangeLog,v 1.107 2012/03/08 16:40:50 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/ChangeLog,v 1.108 2012/03/08 18:20:32 cardoe Exp $
+
+ 08 Mar 2012; Doug Goldstein <cardoe@gentoo.org> qemu-kvm-1.0-r3.ebuild:
+ Remove the backslash gluing which was causing odd spacing. Make KVM optional
+ in the kernel for mgorny.
08 Mar 2012; Doug Goldstein <cardoe@gentoo.org> qemu-kvm-1.0-r3.ebuild:
Warn about KVM_INTEL and KVM_AMD and don't require both to be present bug
diff --git a/app-emulation/qemu-kvm/qemu-kvm-1.0-r3.ebuild b/app-emulation/qemu-kvm/qemu-kvm-1.0-r3.ebuild
index 843544f3048f..2a1f1555c9f3 100644
--- a/app-emulation/qemu-kvm/qemu-kvm-1.0-r3.ebuild
+++ b/app-emulation/qemu-kvm/qemu-kvm-1.0-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/qemu-kvm-1.0-r3.ebuild,v 1.8 2012/03/08 16:40:50 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu-kvm/qemu-kvm-1.0-r3.ebuild,v 1.9 2012/03/08 18:20:32 cardoe Exp $
#BACKPORTS=1
@@ -144,20 +144,20 @@ pkg_pretend() {
if ! linux_config_exists; then
eerror "Unable to check your kernel for KVM support"
else
- CONFIG_CHECK="KVM ~KVM_AMD ~KVM_INTEL ~TUN ~BRIDGE"
+ CONFIG_CHECK="~KVM ~KVM_AMD ~KVM_INTEL ~TUN ~BRIDGE"
ERROR_KVM="You must enable KVM in your kernel to continue"
- ERROR_KVM_AMD="If you have an AMD CPU, you must enable KVM_AMD in \
- your kernel configuration."
- ERROR_KVM_INTEL="If you have an Intel CPU, you must enable \
- KVM_INTEL in your kernel configuration."
- ERROR_TUN="You will need the Universal TUN/TAP driver compiled \
- into your kernel or loaded as a module to use the virtual \
- network device if using -net tap."
- ERROR_BRIDGE="You will also need support for 802.1d \
- Ethernet Bridging for some network configurations."
+ ERROR_KVM_AMD="If you have an AMD CPU, you must enable KVM_AMD in "
+ ERROR_KVM_AMD+="your kernel configuration."
+ ERROR_KVM_INTEL="If you have an Intel CPU, you must enable "
+ ERROR_KVM_INTEL+="KVM_INTEL in your kernel configuration."
+ ERROR_TUN="You will need the Universal TUN/TAP driver compiled "
+ ERROR_TUN+="into your kernel or loaded as a module to use the "
+ ERROR_TUN+="virtual network device if using -net tap."
+ ERROR_BRIDGE="You will also need support for 802.1d "
+ ERROR_BRIDGE+="Ethernet Bridging for some network configurations."
use vhost-net && CHECK_CHECK+="~VHOST_NET"
- ERROR_VHOST_NET="You must enable VHOST_NET to have vhost-net \
- support"
+ ERROR_VHOST_NET="You must enable VHOST_NET to have vhost-net "
+ ERROR_VHOST_NET+="support"
# Now do the actual checks setup above
check_extra_config