summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-26 13:02:31 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-26 13:02:31 +0000
commit36dab52f639187182642fd4ddd8b1cc7ed372660 (patch)
tree8e219c33a3199c16844074d4cb3634570947eeb9 /app-emulation/xen
parentFix gcc 4.3 compile failure, part of #259670 (diff)
downloadgentoo-2-36dab52f639187182642fd4ddd8b1cc7ed372660.tar.gz
gentoo-2-36dab52f639187182642fd4ddd8b1cc7ed372660.tar.bz2
gentoo-2-36dab52f639187182642fd4ddd8b1cc7ed372660.zip
Fix gcc 4.3 compile failure, part of #259670
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation/xen')
-rw-r--r--app-emulation/xen/ChangeLog6
-rw-r--r--app-emulation/xen/files/xen-3.3.0-warning-fix.patch26
-rw-r--r--app-emulation/xen/xen-3.3.0.ebuild8
3 files changed, 37 insertions, 3 deletions
diff --git a/app-emulation/xen/ChangeLog b/app-emulation/xen/ChangeLog
index 88b2fed7d3e4..7695fff8a607 100644
--- a/app-emulation/xen/ChangeLog
+++ b/app-emulation/xen/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/xen
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.57 2009/02/28 10:19:07 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.58 2009/04/26 13:02:31 patrick Exp $
+
+ 26 Apr 2009; Patrick Lauer <patrick@gentoo.org>
+ +files/xen-3.3.0-warning-fix.patch, xen-3.3.0:
+ Fix gcc 4.3 compile failure, part of #259670
28 Feb 2009; Markus Meier <maekke@gentoo.org> metadata.xml:
custom-cflags is a global USE-flag
diff --git a/app-emulation/xen/files/xen-3.3.0-warning-fix.patch b/app-emulation/xen/files/xen-3.3.0-warning-fix.patch
new file mode 100644
index 000000000000..d1cc78c322bc
--- /dev/null
+++ b/app-emulation/xen/files/xen-3.3.0-warning-fix.patch
@@ -0,0 +1,26 @@
+diff -Nru a/xen/drivers/char/console.c b/xen/drivers/char/console.c
+--- a/xen/drivers/char/console.c 2008-08-22 17:49:09.000000000 +0800
++++ b/xen/drivers/char/console.c 2009-02-19 18:39:47.000000000 +0800
+@@ -919,7 +919,7 @@
+ console_start_sync();
+ printk("\n****************************************\n");
+ printk("Panic on CPU %d:\n", smp_processor_id());
+- printk(buf);
++ printk("%s", buf);
+ printk("****************************************\n\n");
+ if ( opt_noreboot )
+ printk("Manual reset required ('noreboot' specified)\n");
+diff -Nru a/xen/tools/symbols.c b/xen/tools/symbols.c
+--- a/xen/tools/symbols.c 2008-08-22 17:49:10.000000000 +0800
++++ b/xen/tools/symbols.c 2009-02-19 18:36:35.000000000 +0800
+@@ -80,8 +80,9 @@
+ rc = fscanf(in, "%llx %c %499s\n", &s->addr, &stype, str);
+ if (rc != 3) {
+ if (rc != EOF) {
++ char* z;
+ /* skip line */
+- fgets(str, 500, in);
++ z = fgets(str, 500, in);
+ }
+ return -1;
+ }
diff --git a/app-emulation/xen/xen-3.3.0.ebuild b/app-emulation/xen/xen-3.3.0.ebuild
index 6b76ff98aa1b..4f9ffbb249c7 100644
--- a/app-emulation/xen/xen-3.3.0.ebuild
+++ b/app-emulation/xen/xen-3.3.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.3.0.ebuild,v 1.1 2008/09/01 00:30:53 rbu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-3.3.0.ebuild,v 1.2 2009/04/26 13:02:31 patrick Exp $
inherit mount-boot flag-o-matic toolchain-funcs
@@ -54,6 +54,10 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${PN}-sed-gcc.patch
+ # Fix compiler warning on gcc 4.3.3
+ epatch "${FILESDIR}/${P}-warning-fix.patch"
+
+
# if the user *really* wants to use their own custom-cflags, let them
if use custom-cflags; then
einfo "User wants their own CFLAGS - removing defaults"