summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-01-04 06:23:01 +0000
committerTim Harder <radhermit@gentoo.org>2014-01-04 06:23:01 +0000
commit5af59c3df8fb64461af53808e08d87b2c25b9261 (patch)
tree28a91c4b9d047e83843129d7fd7b94c62457ff3c /app-emulation/vagrant
parentRemove old. (diff)
downloadgentoo-2-5af59c3df8fb64461af53808e08d87b2c25b9261.tar.gz
gentoo-2-5af59c3df8fb64461af53808e08d87b2c25b9261.tar.bz2
gentoo-2-5af59c3df8fb64461af53808e08d87b2c25b9261.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-emulation/vagrant')
-rw-r--r--app-emulation/vagrant/ChangeLog9
-rw-r--r--app-emulation/vagrant/vagrant-1.4.3.ebuild67
2 files changed, 74 insertions, 2 deletions
diff --git a/app-emulation/vagrant/ChangeLog b/app-emulation/vagrant/ChangeLog
index 521dc2899d12..c549a83747f4 100644
--- a/app-emulation/vagrant/ChangeLog
+++ b/app-emulation/vagrant/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/vagrant
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vagrant/ChangeLog,v 1.31 2013/12/21 23:10:04 radhermit Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vagrant/ChangeLog,v 1.32 2014/01/04 06:23:01 radhermit Exp $
+
+*vagrant-1.4.3 (04 Jan 2014)
+
+ 04 Jan 2014; Tim Harder <radhermit@gentoo.org> +vagrant-1.4.3.ebuild:
+ Version bump.
*vagrant-1.4.1 (21 Dec 2013)
diff --git a/app-emulation/vagrant/vagrant-1.4.3.ebuild b/app-emulation/vagrant/vagrant-1.4.3.ebuild
new file mode 100644
index 000000000000..0416fe233602
--- /dev/null
+++ b/app-emulation/vagrant/vagrant-1.4.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vagrant/vagrant-1.4.3.ebuild,v 1.1 2014/01/04 06:23:01 radhermit Exp $
+
+EAPI="5"
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+RUBY_FAKEGEM_GEMSPEC="vagrant.gemspec"
+RUBY_FAKEGEM_EXTRAINSTALL="config keys plugins templates"
+RUBY_FAKEGEM_TASK_DOC=""
+
+inherit ruby-fakegem eutils
+
+DESCRIPTION="A tool for building and distributing virtual machines using VirtualBox"
+HOMEPAGE="http://vagrantup.com/"
+SRC_URI="https://github.com/mitchellh/vagrant/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="test"
+
+# Missing ebuild for contest
+RESTRICT="test"
+
+RDEPEND="${RDEPEND}
+ net-misc/curl
+ !x64-macos? ( || ( app-emulation/virtualbox app-emulation/virtualbox-bin ) )"
+
+ruby_add_rdepend "
+ >=dev-ruby/childprocess-0.3.7
+ >=dev-ruby/erubis-2.7.0
+ dev-ruby/i18n:0.6
+ >=dev-ruby/json-1.5.1
+ >=dev-ruby/log4r-1.1.9
+ >=dev-ruby/net-ssh-2.6.6
+ >=dev-ruby/net-scp-1.1.0
+"
+
+ruby_add_bdepend "
+ dev-ruby/rake
+ test? ( dev-ruby/mocha virtual/ruby-minitest )
+"
+
+all_ruby_prepare() {
+ # remove bundler support
+ sed -i '/[Bb]undler/d' Rakefile || die
+ rm Gemfile || die
+
+ # loosen dependencies
+ sed -e '/childprocess\|erubis\|log4r\|net-scp\|net-ssh/s/~>/>=/' \
+ -i ${PN}.gemspec || die
+
+ epatch "${FILESDIR}"/${PN}-1.2.1-no-warning.patch
+ epatch "${FILESDIR}"/${PN}-1.2.2-rvm.patch
+}
+
+pkg_postinst() {
+ if use x64-macos ; then
+ ewarn
+ ewarn "For Mac OS X prefixes, you must install the virtualbox"
+ ewarn "package specifically for OS X which can be found at:"
+ ewarn "https://www.virtualbox.org/wiki/Downloads"
+ ewarn
+ fi
+}