summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-11-30 10:43:39 +0000
committerUlrich Müller <ulm@gentoo.org>2008-11-30 10:43:39 +0000
commite0f660a3bc1c307657c7e21b81ceaad9059c2a69 (patch)
tree7acb882176f9bf2e3e5d87f748192f41aab6fcb1 /app-emacs
parentPackage mask app-emacs/emacs-daemon. (diff)
downloadgentoo-2-e0f660a3bc1c307657c7e21b81ceaad9059c2a69.tar.gz
gentoo-2-e0f660a3bc1c307657c7e21b81ceaad9059c2a69.tar.bz2
gentoo-2-e0f660a3bc1c307657c7e21b81ceaad9059c2a69.zip
Initial import.
(Portage version: 2.2_rc16/cvs/Linux 2.6.27-gentoo-r4 i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/emacs-daemon/ChangeLog10
-rw-r--r--app-emacs/emacs-daemon/emacs-daemon-0.7.ebuild41
-rw-r--r--app-emacs/emacs-daemon/metadata.xml5
3 files changed, 56 insertions, 0 deletions
diff --git a/app-emacs/emacs-daemon/ChangeLog b/app-emacs/emacs-daemon/ChangeLog
new file mode 100644
index 000000000000..02b5821cf775
--- /dev/null
+++ b/app-emacs/emacs-daemon/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-emacs/emacs-daemon
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-daemon/ChangeLog,v 1.1 2008/11/30 10:43:39 ulm Exp $
+
+*emacs-daemon-0.7 (30 Nov 2008)
+
+ 30 Nov 2008; Ulrich Mueller <ulm@gentoo.org> +metadata.xml,
+ +emacs-daemon-0.7.ebuild:
+ Initial import. Ebuild contributed by me.
+
diff --git a/app-emacs/emacs-daemon/emacs-daemon-0.7.ebuild b/app-emacs/emacs-daemon/emacs-daemon-0.7.ebuild
new file mode 100644
index 000000000000..a7eb87755804
--- /dev/null
+++ b/app-emacs/emacs-daemon/emacs-daemon-0.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/emacs-daemon/emacs-daemon-0.7.ebuild,v 1.1 2008/11/30 10:43:39 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Gentoo support for Emacs running as a server in the background"
+HOMEPAGE="http://www.gentoo.org/proj/en/lisp/emacs/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/emacs-23"
+RDEPEND="${DEPEND}
+ >=sys-apps/openrc-0.3.0-r1"
+
+SITEFILE="10${PN}-gentoo.el"
+
+pkg_setup() {
+ local has_daemon=$(${EMACS} ${EMACSFLAGS} \
+ --eval "(princ (fboundp 'daemonp))")
+ if [ "${has_daemon}" != t ]; then
+ ewarn "Your current Emacs version does not support running as a daemon"
+ ewarn "which is required for ${CATEGORY}/${PN}."
+ ewarn "Use \"eselect emacs\" to select an Emacs version >= 23."
+ fi
+}
+
+src_compile() { :; }
+
+src_install() {
+ newinitd emacs.rc emacs || die
+ newconfd emacs.conf emacs || die
+ exeinto /usr/libexec/emacs
+ doexe emacs-wrapper.sh || die
+ elisp-site-file-install "${SITEFILE}" || die
+ keepdir /var/run/emacs || die
+}
diff --git a/app-emacs/emacs-daemon/metadata.xml b/app-emacs/emacs-daemon/metadata.xml
new file mode 100644
index 000000000000..bc306fe58224
--- /dev/null
+++ b/app-emacs/emacs-daemon/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>emacs</herd>
+</pkgmetadata>