summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2012-11-02 17:00:09 +0000
committerUlrich Müller <ulm@gentoo.org>2012-11-02 17:00:09 +0000
commit0da7ea46e0d86d0f2ab09ac8cebf2b3c125b6364 (patch)
treedbd5478c327217d6203614548c976ebbb89844af /app-emacs/sml-mode
parentdev-tcltk/tkXwin: Drop old (diff)
downloadgentoo-2-0da7ea46e0d86d0f2ab09ac8cebf2b3c125b6364.tar.gz
gentoo-2-0da7ea46e0d86d0f2ab09ac8cebf2b3c125b6364.tar.bz2
gentoo-2-0da7ea46e0d86d0f2ab09ac8cebf2b3c125b6364.zip
Fix site initialisation, bug 440882.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key E7BE08CA7DC6EA25)
Diffstat (limited to 'app-emacs/sml-mode')
-rw-r--r--app-emacs/sml-mode/ChangeLog8
-rw-r--r--app-emacs/sml-mode/files/50sml-mode-gentoo-6.1.el2
-rw-r--r--app-emacs/sml-mode/sml-mode-6.1-r1.ebuild (renamed from app-emacs/sml-mode/sml-mode-6.1.ebuild)9
3 files changed, 16 insertions, 3 deletions
diff --git a/app-emacs/sml-mode/ChangeLog b/app-emacs/sml-mode/ChangeLog
index 20fe84ff0e5e..9cbecb689290 100644
--- a/app-emacs/sml-mode/ChangeLog
+++ b/app-emacs/sml-mode/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emacs/sml-mode
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/sml-mode/ChangeLog,v 1.26 2012/11/01 14:42:24 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/sml-mode/ChangeLog,v 1.27 2012/11/02 17:00:09 ulm Exp $
+
+*sml-mode-6.1-r1 (02 Nov 2012)
+
+ 02 Nov 2012; Ulrich Müller <ulm@gentoo.org> -sml-mode-6.1.ebuild,
+ +sml-mode-6.1-r1.ebuild, +files/50sml-mode-gentoo-6.1.el:
+ Fix site initialisation, bug 440882.
*sml-mode-6.1 (01 Nov 2012)
diff --git a/app-emacs/sml-mode/files/50sml-mode-gentoo-6.1.el b/app-emacs/sml-mode/files/50sml-mode-gentoo-6.1.el
new file mode 100644
index 000000000000..feb0eb3a9551
--- /dev/null
+++ b/app-emacs/sml-mode/files/50sml-mode-gentoo-6.1.el
@@ -0,0 +1,2 @@
+(add-to-list 'load-path "@SITELISP@")
+(load "sml-mode-autoloads" nil t)
diff --git a/app-emacs/sml-mode/sml-mode-6.1.ebuild b/app-emacs/sml-mode/sml-mode-6.1-r1.ebuild
index 1671a4ff229c..d44c39ab3495 100644
--- a/app-emacs/sml-mode/sml-mode-6.1.ebuild
+++ b/app-emacs/sml-mode/sml-mode-6.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/sml-mode/sml-mode-6.1.ebuild,v 1.1 2012/11/01 14:42:24 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/sml-mode/sml-mode-6.1-r1.ebuild,v 1.1 2012/11/02 17:00:09 ulm Exp $
EAPI=4
@@ -17,4 +17,9 @@ KEYWORDS="~alpha ~amd64 ~ppc ~x86"
DEPEND="app-arch/xz-utils"
-SITEFILE="50${PN}-gentoo.el"
+SITEFILE="50${PN}-gentoo-${PV}.el"
+
+src_compile() {
+ elisp-compile *.el || die
+ elisp-make-autoload-file || die
+}