summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-04-24 11:35:52 +0000
committerJohannes Huber <johu@gentoo.org>2012-04-24 11:35:52 +0000
commit5868c241ee3096f1c5768abc2b31eee9d8d23081 (patch)
tree89420579364aa45d656314606e74258d3956e7ac /app-editors/tea
parentFix PYTHON_MODNAME (diff)
downloadgentoo-2-5868c241ee3096f1c5768abc2b31eee9d8d23081.tar.gz
gentoo-2-5868c241ee3096f1c5768abc2b31eee9d8d23081.tar.bz2
gentoo-2-5868c241ee3096f1c5768abc2b31eee9d8d23081.zip
Version bump, remove old.
(Portage version: 2.2.0_alpha101/cvs/Linux i686)
Diffstat (limited to 'app-editors/tea')
-rw-r--r--app-editors/tea/ChangeLog8
-rw-r--r--app-editors/tea/tea-32.0.0.ebuild48
-rw-r--r--app-editors/tea/tea-32.0.2.ebuild (renamed from app-editors/tea/tea-31.2.0.ebuild)34
3 files changed, 34 insertions, 56 deletions
diff --git a/app-editors/tea/ChangeLog b/app-editors/tea/ChangeLog
index 555b5b4d1929..b736db34b3e8 100644
--- a/app-editors/tea/ChangeLog
+++ b/app-editors/tea/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-editors/tea
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.53 2012/03/16 15:17:52 pesa Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/ChangeLog,v 1.54 2012/04/24 11:35:52 johu Exp $
+
+*tea-32.0.2 (24 Apr 2012)
+
+ 24 Apr 2012; Johannes Huber <johu@gentoo.org> +tea-32.0.2.ebuild,
+ -tea-31.2.0.ebuild, -tea-32.0.0.ebuild:
+ Version bump, remove old.
*tea-32.0.1 (16 Mar 2012)
diff --git a/app-editors/tea/tea-32.0.0.ebuild b/app-editors/tea/tea-32.0.0.ebuild
deleted file mode 100644
index 0b327089d8b9..000000000000
--- a/app-editors/tea/tea-32.0.0.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/tea-32.0.0.ebuild,v 1.1 2012/03/16 10:23:30 patrick Exp $
-
-EAPI=4
-inherit eutils qt4-r2
-
-DESCRIPTION="Small, lightweight Qt text editor"
-HOMEPAGE="http://tea-editor.sourceforge.net/"
-SRC_URI="mirror://sourceforge/tea-editor/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~x86 ~x86-fbsd"
-IUSE="aspell hunspell"
-
-RDEPEND="sys-libs/zlib
- x11-libs/qt-core:4
- x11-libs/qt-gui:4
- aspell? ( app-text/aspell )
- hunspell? ( app-text/hunspell )"
-DEPEND="${RDEPEND}
- hunspell? ( dev-util/pkgconfig )"
-
-src_configure() {
- local myopts
- if use aspell ; then
- myopts="USE_ASPELL=true"
- else
- myopts="USE_ASPELL=false"
- fi
-
- if use hunspell ; then
- myopts="${myopts} USE_HUNSPELL=true"
- else
- myopts="${myopts} USE_HUNSPELL=false"
- fi
-
- eqmake4 src.pro PREFIX="/usr/bin" ${myopts}
-}
-
-src_install() {
- dobin bin/tea
- dodoc AUTHORS ChangeLog NEWS NEWS-RU TODO
- doicon icons/tea_icon_v2.png
-
- make_desktop_entry tea Tea tea_icon_v2 Utility
-}
diff --git a/app-editors/tea/tea-31.2.0.ebuild b/app-editors/tea/tea-32.0.2.ebuild
index 89d701898dd5..bcaeb81185a4 100644
--- a/app-editors/tea/tea-31.2.0.ebuild
+++ b/app-editors/tea/tea-32.0.2.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/tea-31.2.0.ebuild,v 1.1 2012/01/21 22:08:26 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/tea/tea-32.0.2.ebuild,v 1.1 2012/04/24 11:35:52 johu Exp $
EAPI=4
+LANGS="de fr ru"
+
inherit eutils qt4-r2
DESCRIPTION="Small, lightweight Qt text editor"
@@ -22,15 +24,18 @@ RDEPEND="sys-libs/zlib
DEPEND="${RDEPEND}
hunspell? ( dev-util/pkgconfig )"
+DOCS="AUTHORS ChangeLog NEWS TODO"
+
src_configure() {
local myopts
- if use aspell ; then
+
+ if use aspell; then
myopts="USE_ASPELL=true"
else
myopts="USE_ASPELL=false"
fi
- if use hunspell ; then
+ if use hunspell; then
myopts="${myopts} USE_HUNSPELL=true"
else
myopts="${myopts} USE_HUNSPELL=false"
@@ -40,9 +45,24 @@ src_configure() {
}
src_install() {
- dobin bin/tea
- dodoc AUTHORS ChangeLog NEWS NEWS-RU TODO
- doicon icons/tea_icon_v2.png
+ qt4-r2_src_install
- make_desktop_entry tea Tea tea_icon_v2 Utility
+ newicon icons/tea_icon_v2.png ${PN}.png
+ make_desktop_entry ${PN} Tea ${PN}
+
+ # translations
+ insinto /usr/share/qt4/translations
+ local lang
+ for lang in ${LANGS}; do
+ if use linguas_${lang}; then
+ doins translations/${PN}_${lang}.qm
+ fi
+ done
+
+ # docs
+ dohtml manuals/en.html
+ if use linguas_ru; then
+ dodoc NEWS-RU
+ dohtml manuals/ru.html
+ fi
}