summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2013-12-08 19:57:54 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2013-12-08 19:57:54 +0000
commit93cb94e53a19e693e6285cbaf680a26dd2ae3cce (patch)
tree48dad41ee05574e1c2a5f2cb6d65d8a0c8c9317a /app-crypt
parentx86 stable, bug #478252 (diff)
downloadgentoo-2-93cb94e53a19e693e6285cbaf680a26dd2ae3cce.tar.gz
gentoo-2-93cb94e53a19e693e6285cbaf680a26dd2ae3cce.tar.bz2
gentoo-2-93cb94e53a19e693e6285cbaf680a26dd2ae3cce.zip
Force dl library, bug#481060
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key BF20DC51)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/truecrypt/ChangeLog6
-rw-r--r--app-crypt/truecrypt/files/truecrypt-7.1a-build.patch16
-rw-r--r--app-crypt/truecrypt/truecrypt-7.1a.ebuild3
3 files changed, 23 insertions, 2 deletions
diff --git a/app-crypt/truecrypt/ChangeLog b/app-crypt/truecrypt/ChangeLog
index 101a72be81a7..86be233df8cc 100644
--- a/app-crypt/truecrypt/ChangeLog
+++ b/app-crypt/truecrypt/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/truecrypt
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.76 2013/06/02 10:55:49 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/ChangeLog,v 1.77 2013/12/08 19:57:54 alonbl Exp $
+
+ 08 Dec 2013; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/truecrypt-7.1a-build.patch, truecrypt-7.1a.ebuild:
+ Force dl library, bug#481060
02 Jun 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due bug #328951
diff --git a/app-crypt/truecrypt/files/truecrypt-7.1a-build.patch b/app-crypt/truecrypt/files/truecrypt-7.1a-build.patch
new file mode 100644
index 000000000000..e0b05d503b64
--- /dev/null
+++ b/app-crypt/truecrypt/files/truecrypt-7.1a-build.patch
@@ -0,0 +1,16 @@
+Add dl library, bug#481060.
+
+---
+
+diff -urNp truecrypt-7.1a-source.org/Main/Main.make truecrypt-7.1a-source/Main/Main.make
+--- truecrypt-7.1a-source.org/Main/Main.make 2012-02-07 12:36:48.000000000 +0200
++++ truecrypt-7.1a-source/Main/Main.make 2013-12-08 21:50:07.224586712 +0200
+@@ -105,7 +105,7 @@ TC_VERSION = $(shell grep VERSION_STRING
+
+ $(APPNAME): $(LIBS) $(OBJS)
+ @echo Linking $@
+- $(CXX) -o $(APPNAME) $(LFLAGS) $(OBJS) $(LIBS) $(FUSE_LIBS) $(WX_LIBS)
++ $(CXX) -o $(APPNAME) $(LFLAGS) $(OBJS) $(LIBS) $(FUSE_LIBS) $(WX_LIBS) -ldl
+
+ ifeq "$(TC_BUILD_CONFIG)" "Release"
+ ifndef NOSTRIP
diff --git a/app-crypt/truecrypt/truecrypt-7.1a.ebuild b/app-crypt/truecrypt/truecrypt-7.1a.ebuild
index e40c51bec8a2..8a1c51df084a 100644
--- a/app-crypt/truecrypt/truecrypt-7.1a.ebuild
+++ b/app-crypt/truecrypt/truecrypt-7.1a.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-7.1a.ebuild,v 1.6 2013/04/09 10:14:47 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/truecrypt/truecrypt-7.1a.ebuild,v 1.7 2013/12/08 19:57:54 alonbl Exp $
EAPI="4"
@@ -58,6 +58,7 @@ src_prepare() {
epatch "${FILESDIR}/makefile-archdetect.diff"
epatch "${FILESDIR}/execstack-fix.diff"
+ epatch "${FILESDIR}/${P}-build.patch"
mkdir "${T}"/pkcs11 || die
ln -s "${DISTDIR}"/${P}-pkcs11.h "${T}"/pkcs11/pkcs11.h || die
}