summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-05-21 18:51:53 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-05-21 18:51:53 +0000
commit5ea1eb709812ed47f7cb0cb2e56bb265457c6c1f (patch)
tree0a7322f5b6345091f306282dcd8e71322bc509c9 /app-crypt
parentStable on ppc64 (diff)
downloadgentoo-2-5ea1eb709812ed47f7cb0cb2e56bb265457c6c1f.tar.gz
gentoo-2-5ea1eb709812ed47f7cb0cb2e56bb265457c6c1f.tar.bz2
gentoo-2-5ea1eb709812ed47f7cb0cb2e56bb265457c6c1f.zip
New gnupg with gpg2-experimental, currently masked, thanks to taviso and bug 132343
(Portage version: 2.1_rc1-r2)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gnupg/ChangeLog9
-rw-r--r--app-crypt/gnupg/files/digest-gnupg-1.9.20-r33
-rw-r--r--app-crypt/gnupg/gnupg-1.9.20-r3.ebuild104
3 files changed, 115 insertions, 1 deletions
diff --git a/app-crypt/gnupg/ChangeLog b/app-crypt/gnupg/ChangeLog
index 5bbb85c6f318..3f3548028859 100644
--- a/app-crypt/gnupg/ChangeLog
+++ b/app-crypt/gnupg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-crypt/gnupg
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.186 2006/05/17 12:12:41 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/ChangeLog,v 1.187 2006/05/21 18:51:53 genstef Exp $
+
+*gnupg-1.9.20-r3 (21 May 2006)
+
+ 21 May 2006; Stefan Schweizer <genstef@gentoo.org>
+ +gnupg-1.9.20-r3.ebuild:
+ New gnupg with gpg2-experimental, currently masked, thanks to taviso and bug
+ 132343
17 May 2006; Diego Pettenò <flameeyes@gentoo.org>
+files/gnupg-1.9.20-fbsd.patch, gnupg-1.9.20-r2.ebuild:
diff --git a/app-crypt/gnupg/files/digest-gnupg-1.9.20-r3 b/app-crypt/gnupg/files/digest-gnupg-1.9.20-r3
new file mode 100644
index 000000000000..ba3b6d7aa814
--- /dev/null
+++ b/app-crypt/gnupg/files/digest-gnupg-1.9.20-r3
@@ -0,0 +1,3 @@
+MD5 93899203fc0530f03e146d49b65c1e28 gnupg-1.9.20.tar.bz2 1810059
+RMD160 3501de32f1526f64510a77fe3cc0905dd7fc8854 gnupg-1.9.20.tar.bz2 1810059
+SHA256 6272727e5a0e019743e8520a2ff6b42eb4cc89251cb5bbca73dda09cb765487e gnupg-1.9.20.tar.bz2 1810059
diff --git a/app-crypt/gnupg/gnupg-1.9.20-r3.ebuild b/app-crypt/gnupg/gnupg-1.9.20-r3.ebuild
new file mode 100644
index 000000000000..6052e88813cf
--- /dev/null
+++ b/app-crypt/gnupg/gnupg-1.9.20-r3.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gnupg/gnupg-1.9.20-r3.ebuild,v 1.1 2006/05/21 18:51:53 genstef Exp $
+
+inherit eutils flag-o-matic autotools
+
+DESCRIPTION="The GNU Privacy Guard, a GPL pgp replacement"
+HOMEPAGE="http://www.gnupg.org/"
+SRC_URI="mirror://gnupg/alpha/gnupg/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="1.9"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ia64 ~mips ~ppc ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="X caps gpg2-experimental ldap nls smartcard selinux"
+
+COMMON_DEPEND="
+ dev-lang/perl
+ sys-libs/zlib
+ virtual/libc
+ >=dev-libs/pth-1.3.7
+ smartcard? ( >=dev-libs/opensc-0.8.0 )
+ >=dev-libs/libgcrypt-1.1.94
+ >=dev-libs/libksba-0.9.13
+ >=dev-libs/libgpg-error-1.0
+ ~dev-libs/libassuan-0.6.10
+ ldap? ( net-nds/openldap )
+ caps? ( sys-libs/libcap )"
+
+DEPEND="${COMMON_DEPEND}
+ nls? ( sys-devel/gettext )"
+
+RDEPEND="${COMMON_DEPEND}
+ !app-crypt/gpg-agent
+ =app-crypt/gnupg-1.4*
+ X? ( || ( media-gfx/xloadimage media-gfx/xli ) )
+ virtual/mta
+ selinux? ( sec-policy/selinux-gnupg )
+ nls? ( virtual/libintl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ if use smartcard && ! built_with_use dev-libs/opensc pcsc-lite ; then
+ sed -i -e 's:OPENSC_LIBS="\$OPENSC_LIBS -lpcsclite -lpthread":OPENSC_LIBS="\$OPENSC_LIBS -lopenct -lpthread":' \
+ acinclude.m4 || die "openct patching failed."
+ ./autogen.sh
+ fi
+ sed -i -e 's/PIC/__PIC__/g' intl/relocatable.c || die "PIC patching failed"
+
+ epatch "${FILESDIR}/${P}-fbsd.patch"
+ AT_M4DIR="m4 gl/m4" eautoreconf
+}
+
+src_compile() {
+ local myconf=""
+
+ if use X; then
+ local viewer
+ if has_version 'media-gfx/xloadimage'; then
+ viewer=/usr/bin/xloadimage
+ else
+ viewer=/usr/bin/xli
+ fi
+ myconf="${myconf} --with-photo-viewer=${viewer}"
+ else
+ myconf="${myconf} --disable-photo-viewers"
+ fi
+
+ use caps || append-ldflags $(bindnow-flags)
+
+ econf \
+ --enable-agent \
+ --enable-symcryptrun \
+ $(use_enable gpg2-experimental gpg) \
+ --enable-gpgsm \
+ $(use_enable smartcard scdaemon) \
+ $(use_enable nls) \
+ $(use_enable ldap) \
+ $(use_with caps capabilities) \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc ChangeLog NEWS README THANKS TODO VERSION
+
+ if ! use caps; then
+ use gpg2-experimental && fperms u+s,go-r /usr/bin/gpg2
+ fperms u+s,go-r /usr/bin/gpg-agent
+ fi
+}
+
+pkg_postinst() {
+ if ! use caps; then
+ einfo "gpg is installed suid root to make use of protected memory space"
+ einfo "This is needed in order to have a secure place to store your"
+ einfo "passphrases, etc. at runtime but may make some sysadmins nervous."
+ fi
+ einfo
+ einfo "See http://www.gentoo.org/doc/en/gnupg-user.xml for documentation on gnupg"
+ einfo
+}