summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2008-01-15 18:26:03 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2008-01-15 18:26:03 +0000
commit2cb226eb5e70a3d50c1aeaf49d52cc144ce24c0f (patch)
tree268e7e12ad425199945b4b0dc4f72ced73993b97 /app-crypt
parentDropped ppc-macos keyword, see you in prefix (diff)
downloadgentoo-2-2cb226eb5e70a3d50c1aeaf49d52cc144ce24c0f.tar.gz
gentoo-2-2cb226eb5e70a3d50c1aeaf49d52cc144ce24c0f.tar.bz2
gentoo-2-2cb226eb5e70a3d50c1aeaf49d52cc144ce24c0f.zip
Version bump + some corrections from cvs
(Portage version: 2.1.4, RepoMan options: --force)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/gpgme/ChangeLog8
-rw-r--r--app-crypt/gpgme/files/digest-gpgme-1.1.63
-rw-r--r--app-crypt/gpgme/files/gpgme-1.1.6-cvs.patch192
-rw-r--r--app-crypt/gpgme/gpgme-1.1.6.ebuild48
4 files changed, 250 insertions, 1 deletions
diff --git a/app-crypt/gpgme/ChangeLog b/app-crypt/gpgme/ChangeLog
index 1ea31b4fffb3..469dd03758be 100644
--- a/app-crypt/gpgme/ChangeLog
+++ b/app-crypt/gpgme/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-crypt/gpgme
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/ChangeLog,v 1.128 2008/01/02 18:26:44 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/ChangeLog,v 1.129 2008/01/15 18:26:02 alonbl Exp $
+
+*gpgme-1.1.6 (15 Jan 2008)
+
+ 15 Jan 2008; Alon Bar-Lev <alonbl@gentoo.org>
+ +files/gpgme-1.1.6-cvs.patch, +gpgme-1.1.6.ebuild:
+ Version bump + some corrections from cvs
02 Jan 2008; Alon Bar-Lev <alonbl@gentoo.org> gpgme-0.3.14-r1.ebuild,
gpgme-1.1.2-r1.ebuild, gpgme-1.1.5.ebuild:
diff --git a/app-crypt/gpgme/files/digest-gpgme-1.1.6 b/app-crypt/gpgme/files/digest-gpgme-1.1.6
new file mode 100644
index 000000000000..e7030c71fdf7
--- /dev/null
+++ b/app-crypt/gpgme/files/digest-gpgme-1.1.6
@@ -0,0 +1,3 @@
+MD5 df7ab717bf9b0189bd76b06c0c8a2509 gpgme-1.1.6.tar.gz 961286
+RMD160 b761fed5ad88ef4b467c981bcc0ef95317c11ac1 gpgme-1.1.6.tar.gz 961286
+SHA256 7cf6cd9dfc1f02488eab8cb8a64d3904c71df9a04b1e9614beeec72dbde3f49f gpgme-1.1.6.tar.gz 961286
diff --git a/app-crypt/gpgme/files/gpgme-1.1.6-cvs.patch b/app-crypt/gpgme/files/gpgme-1.1.6-cvs.patch
new file mode 100644
index 000000000000..a9ef27a64694
--- /dev/null
+++ b/app-crypt/gpgme/files/gpgme-1.1.6-cvs.patch
@@ -0,0 +1,192 @@
+diff -urNp gpgme-1.1.6.org/assuan/assuan-pipe-connect.c gpgme.svn/assuan/assuan-pipe-connect.c
+--- gpgme-1.1.6.org/assuan/assuan-pipe-connect.c 2007-09-27 15:00:05.000000000 +0200
++++ gpgme.svn/assuan/assuan-pipe-connect.c 2008-01-04 18:06:42.000000000 +0200
+@@ -39,6 +39,14 @@
+
+ #include "assuan-defs.h"
+
++#ifdef _ASSUAN_IN_GPGME_BUILD_ASSUAN
++
++int _gpgme_io_pipe (int filedes[2], int inherit_idx);
++int _gpgme_io_spawn (const char *path, char **argv,
++ struct spawn_fd_item_s *fd_child_list,
++ struct spawn_fd_item_s *fd_parent_list);
++#endif
++
+ /* Hacks for Slowaris. */
+ #ifndef PF_LOCAL
+ # ifdef PF_UNIX
+diff -urNp gpgme-1.1.6.org/gpgme/engine-gpgconf.c gpgme.svn/gpgme/engine-gpgconf.c
+--- gpgme-1.1.6.org/gpgme/engine-gpgconf.c 2008-01-04 16:17:15.000000000 +0200
++++ gpgme.svn/gpgme/engine-gpgconf.c 2008-01-14 19:34:21.000000000 +0200
+@@ -313,8 +310,8 @@ gpgconf_config_load_cb (void *hook, char
+
+ if (fields >= 3)
+ {
+- comp->description = strdup (field[2]);
+- if (!comp->description)
++ comp->program_name = strdup (field[2]);
++ if (!comp->program_name)
+ return gpg_error_from_syserror ();
+ }
+
+@@ -457,9 +454,18 @@ gpgconf_config_load_cb2 (void *hook, cha
+ return gpg_error_from_syserror ();
+ }
+
+- err = gpgconf_parse_option (opt, &opt->no_arg_value, field[8]);
+- if (err)
+- return err;
++ if (opt->flags & GPGME_CONF_NO_ARG_DESC)
++ {
++ opt->no_arg_description = strdup (field[8]);
++ if (!opt->no_arg_description)
++ return gpg_error_from_syserror ();
++ }
++ else
++ {
++ err = gpgconf_parse_option (opt, &opt->no_arg_value, field[8]);
++ if (err)
++ return err;
++ }
+
+ err = gpgconf_parse_option (opt, &opt->value, field[9]);
+ if (err)
+diff -urNp gpgme-1.1.6.org/gpgme/kdpipeiodevice.cpp gpgme.svn/gpgme/kdpipeiodevice.cpp
+--- gpgme-1.1.6.org/gpgme/kdpipeiodevice.cpp 2007-11-12 13:21:58.000000000 +0200
++++ gpgme.svn/gpgme/kdpipeiodevice.cpp 2008-01-10 15:38:34.000000000 +0200
+@@ -329,11 +329,14 @@ void KDPipeIODevice::Private::emitReadyR
+ emit q->readyRead();
+
+ if ( !thisPointer )
+- return;
+- qDebug( "KDPipeIODevice::Private::emitReadyRead %p, %d: locking reader (CONSUMER THREAD)", this, counter );
+- synchronized( reader ) {
+- qDebug( "KDPipeIODevice::Private::emitReadyRead %p, %d: locked reader (CONSUMER THREAD)", this, counter );
+- reader->readyReadSentCondition.wakeAll();
++ return;
++
++ if ( reader ) {
++ qDebug( "KDPipeIODevice::Private::emitReadyRead %p, %d: locking reader (CONSUMER THREAD)", this, counter );
++ synchronized( reader ) {
++ qDebug( "KDPipeIODevice::Private::emitReadyRead %p, %d: locked reader (CONSUMER THREAD)", this, counter );
++ reader->readyReadSentCondition.wakeAll();
++ }
+ }
+ qDebug( "KDPipeIODevice::Private::emitReadyRead %p leaving %d", this, counter );
+
+@@ -704,7 +707,7 @@ void Reader::run() {
+
+ while ( !cancel && !error && bufferFull() ) {
+ notifyReadyRead();
+- if ( bufferFull() ) {
++ if ( !cancel && bufferFull() ) {
+ qDebug( "%p: Reader::run: buffer is full, going to sleep", this );
+ bufferNotFullCondition.wait( &mutex );
+ }
+diff -urNp gpgme-1.1.6.org/tests/gpg/Makefile.am gpgme.svn/tests/gpg/Makefile.am
+--- gpgme-1.1.6.org/tests/gpg/Makefile.am 2008-01-04 16:25:18.000000000 +0200
++++ gpgme.svn/tests/gpg/Makefile.am 2008-01-10 06:40:25.000000000 +0200
+@@ -38,10 +38,10 @@ TESTS = t-encrypt t-encrypt-sym t-encryp
+ t-encrypt-large t-file-name t-gpgconf $(tests_unix)
+
+ CLEANFILES = secring.gpg pubring.gpg pubring.kbx trustdb.gpg dirmngr.conf
+-DISTCLEANFILES = pubring.gpg~ random_seed gpg.conf
++DISTCLEANFILES = pubring.gpg~ random_seed gpg.conf gpg-agent.conf
+
+ EXTRA_DIST = mkdemodirs pubdemo.asc secdemo.asc cipher-1.asc cipher-2.asc \
+- geheim.txt pubkey-1.asc seckey-1.asc
++ geheim.txt pubkey-1.asc seckey-1.asc pinentry
+
+ INCLUDES = -I$(top_srcdir)/gpgme
+
+@@ -55,7 +55,7 @@ noinst_PROGRAMS = $(TESTS) t-genkey
+ clean-local:
+ $(srcdir)/mkdemodirs --clean
+
+-all-local: ./pubring.gpg ./gpg.conf
++all-local: ./pubring.gpg ./gpg.conf ./gpg-agent.conf
+
+ ./pubring.gpg: $(srcdir)/pubdemo.asc ./Alpha/Secret.gpg
+ $(GPG) --homedir . --import $(srcdir)/pubdemo.asc
+@@ -68,3 +68,7 @@ all-local: ./pubring.gpg ./gpg.conf
+ ./gpg.conf:
+ # This is required for t-sig-notations.
+ echo no-force-v3-sigs > ./gpg.conf
++
++./gpg-agent.conf:
++# This is required for gpg2, which does not support command fd.
++ echo pinentry-program $(abs_srcdir)/pinentry > ./gpg-agent.conf
+diff -urNp gpgme-1.1.6.org/tests/gpg/pinentry gpgme.svn/tests/gpg/pinentry
+--- gpgme-1.1.6.org/tests/gpg/pinentry 1970-01-01 02:00:00.000000000 +0200
++++ gpgme.svn/tests/gpg/pinentry 2008-01-10 06:33:34.000000000 +0200
+@@ -0,0 +1,22 @@
++#! /bin/bash
++# Dummy pinentry
++#
++# Copyright 2008 g10 Code GmbH
++#
++# This file is free software; as a special exception the author gives
++# unlimited permission to copy and/or distribute it, with or without
++# modifications, as long as this notice is preserved.
++#
++# This file is distributed in the hope that it will be useful, but
++# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
++# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR
++# PURPOSE.
++
++echo OK Your orders please
++
++while read cmd; do
++ case $cmd in
++ GETPIN) echo D abc; echo OK;;
++ *) echo OK;;
++ esac
++done
+diff -urNp gpgme-1.1.6.org/tests/gpg/t-gpgconf.c gpgme.svn/tests/gpg/t-gpgconf.c
+--- gpgme-1.1.6.org/tests/gpg/t-gpgconf.c 2008-01-04 16:17:15.000000000 +0200
++++ gpgme.svn/tests/gpg/t-gpgconf.c 2008-01-10 06:54:16.000000000 +0200
+@@ -254,6 +254,11 @@ main (int argc, char **argv)
+ gpgme_conf_comp_t conf;
+ gpgme_conf_comp_t comp;
+ int first;
++
++#ifndef ENABLE_GPGCONF
++ return 0;
++#endif
++
+ init_gpgme (GPGME_PROTOCOL_GPGCONF);
+
+ err = gpgme_new (&ctx);
+@@ -287,15 +292,23 @@ main (int argc, char **argv)
+ comp = conf;
+ while (comp && strcmp (comp->name, "dirmngr"))
+ comp = comp->next;
+- opt = comp->options;
+- while (opt && strcmp (opt->name, "verbose"))
+- opt = opt->next;
+
+- err = gpgme_conf_opt_change (opt, 0, arg);
+- fail_if_err (err);
+-
+- err = gpgme_op_conf_save (ctx, comp);
+- fail_if_err (err);
++ if (comp)
++ {
++ opt = comp->options;
++ while (opt && strcmp (opt->name, "verbose"))
++ opt = opt->next;
++
++ /* Allow for the verbose option not to be there. */
++ if (opt)
++ {
++ err = gpgme_conf_opt_change (opt, 0, arg);
++ fail_if_err (err);
++
++ err = gpgme_op_conf_save (ctx, comp);
++ fail_if_err (err);
++ }
++ }
+ }
+ #endif
+
diff --git a/app-crypt/gpgme/gpgme-1.1.6.ebuild b/app-crypt/gpgme/gpgme-1.1.6.ebuild
new file mode 100644
index 000000000000..07e6a137f56c
--- /dev/null
+++ b/app-crypt/gpgme/gpgme-1.1.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/gpgme-1.1.6.ebuild,v 1.1 2008/01/15 18:26:02 alonbl Exp $
+
+inherit autotools eutils
+
+DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
+HOMEPAGE="http://www.gnupg.org/related_software/gpgme"
+SRC_URI="mirror://gnupg/gpgme/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=">=dev-libs/libgpg-error-1.4
+ >=dev-libs/pth-1.2
+ >=app-crypt/gnupg-1.9.20-r1"
+
+RDEPEND="${DEPEND}
+ dev-libs/libgcrypt"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-cvs.patch"
+ chmod a+x "tests/gpg/pinentry"
+ eautoreconf
+
+ # We need to call elibtoolize so that we get sane .so versioning on fbsd.
+ #elibtoolize
+}
+
+src_compile() {
+ econf \
+ --with-pth=yes \
+ --includedir=/usr/include/gpgme \
+ --with-gpg=/usr/bin/gpg \
+ --with-gpgsm=/usr/bin/gpgsm \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO VERSION
+}