summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-12-14 12:43:34 +0000
committerJeroen Roovers <jer@gentoo.org>2009-12-14 12:43:34 +0000
commit1492f22fce338643c95119224ae62c5fe9c5659c (patch)
tree53be0d92ab9219df126e75d6e30a9710eab42568 /app-benchmarks
parentBumping to 1.9.6 and fixing bug #270252 (diff)
downloadgentoo-2-1492f22fce338643c95119224ae62c5fe9c5659c.tar.gz
gentoo-2-1492f22fce338643c95119224ae62c5fe9c5659c.tar.bz2
gentoo-2-1492f22fce338643c95119224ae62c5fe9c5659c.zip
Bump to hopefully fix missing pointer.h (bug #296860).
(Portage version: 2.2_rc59/cvs/Linux i686)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/nbench/ChangeLog10
-rw-r--r--app-benchmarks/nbench/files/nbench-2.2.3-Makefile.patch13
-rw-r--r--app-benchmarks/nbench/nbench-2.2.3-r1.ebuild45
3 files changed, 64 insertions, 4 deletions
diff --git a/app-benchmarks/nbench/ChangeLog b/app-benchmarks/nbench/ChangeLog
index 54bd35d76131..17c42bb5d2b7 100644
--- a/app-benchmarks/nbench/ChangeLog
+++ b/app-benchmarks/nbench/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-benchmarks/nbench
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/nbench/ChangeLog,v 1.23 2009/04/01 14:56:27 jer Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/nbench/ChangeLog,v 1.24 2009/12/14 12:43:34 jer Exp $
+
+*nbench-2.2.3-r1 (14 Dec 2009)
+
+ 14 Dec 2009; Jeroen Roovers <jer@gentoo.org> +nbench-2.2.3-r1.ebuild,
+ files/nbench-2.2.3-Makefile.patch:
+ Bump to hopefully fix missing pointer.h (bug #296860).
01 Apr 2009; Jeroen Roovers <jer@gentoo.org> -nbench-2.2.2.ebuild,
nbench-2.2.3.ebuild:
diff --git a/app-benchmarks/nbench/files/nbench-2.2.3-Makefile.patch b/app-benchmarks/nbench/files/nbench-2.2.3-Makefile.patch
index bf01f55f9936..c41fd07557b7 100644
--- a/app-benchmarks/nbench/files/nbench-2.2.3-Makefile.patch
+++ b/app-benchmarks/nbench/files/nbench-2.2.3-Makefile.patch
@@ -1,5 +1,5 @@
---- nbench-byte-2.2.3/Makefile.orig 2004-12-30 03:23:30.000000000 +0100
-+++ nbench-byte-2.2.3/Makefile 2008-10-29 06:13:34.000000000 +0100
+--- Makefile.org 2004-12-30 03:23:30.000000000 +0100
++++ Makefile 2009-12-14 13:31:18.000000000 +0100
@@ -19,10 +19,10 @@
# You should leave -static in the CFLAGS so that your sysinfo can be
# compiled into the executable.
@@ -13,3 +13,12 @@
# if your gcc lets you do it, then try this one
#CFLAGS = -s -static -Wall -O3 -fomit-frame-pointer -funroll-loops
+@@ -126,7 +126,7 @@
+ if [ "4" = `./pointer` ] ; then touch pointer.h ;\
+ else echo "#define LONG64" >pointer.h ; fi
+
+-misc.o: misc.h misc.c Makefile
++misc.o: misc.h misc.c pointer.h Makefile
+ $(CC) $(MACHINE) $(DEFINES) $(CFLAGS)\
+ -c misc.c
+
diff --git a/app-benchmarks/nbench/nbench-2.2.3-r1.ebuild b/app-benchmarks/nbench/nbench-2.2.3-r1.ebuild
new file mode 100644
index 000000000000..3529b9624de9
--- /dev/null
+++ b/app-benchmarks/nbench/nbench-2.2.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/nbench/nbench-2.2.3-r1.ebuild,v 1.1 2009/12/14 12:43:34 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}-byte-${PV}"
+DESCRIPTION="Linux/Unix of release 2 of BYTE Magazine's BYTEmark benchmark"
+HOMEPAGE="http://www.tux.org/~mayer/linux/bmark.html"
+SRC_URI="http://www.tux.org/~mayer/linux/${MY_P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ cp -va Makefile{,.org}
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+ sed \
+ -e 's:$compiler -v\( 2>&1 | sed -e "/version/!d"\|\):$compiler -dumpversion:' \
+ -i sysinfo.sh || die "patching sysinfo.sh failed"
+ sed -e 's:inpath="NNET.DAT":inpath="/usr/share/nbench/NNET.DAT":' \
+ -i nbench1.h || die "patching nbench1.h failed"
+ #sed \
+ # -e 's|./sysinfo.sh|sh sysinfo.sh|g' \
+ # -i Makefile || die "patching Makefile failed"
+}
+
+src_compile() {
+
+ emake LINKFLAGS="${LDFLAGS}" CC=$(tc-getCC) CFLAGS="${CFLAGS}" || die "make failed"
+}
+
+src_install() {
+ dobin nbench
+ insinto /usr/share/nbench
+ doins NNET.DAT
+
+ dodoc Changes README* bdoc.txt
+}