summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOle Markus With <olemarkus@gentoo.org>2013-07-30 10:10:09 +0000
committerOle Markus With <olemarkus@gentoo.org>2013-07-30 10:10:09 +0000
commit6025c82992ec9e03b150c3ec286b30c252900caa (patch)
treebe01f48808afc5dd792c190a143dcaa95b2f0425 /app-admin/eselect-php
parentStable for amd64, wrt bug #473404 (diff)
downloadgentoo-2-6025c82992ec9e03b150c3ec286b30c252900caa.tar.gz
gentoo-2-6025c82992ec9e03b150c3ec286b30c252900caa.tar.bz2
gentoo-2-6025c82992ec9e03b150c3ec286b30c252900caa.zip
Fix fpm restart issue
(Portage version: 2.1.12.2/cvs/Linux x86_64, signed Manifest commit with key C4A92BF5)
Diffstat (limited to 'app-admin/eselect-php')
-rw-r--r--app-admin/eselect-php/ChangeLog8
-rw-r--r--app-admin/eselect-php/eselect-php-0.7.1-r2.ebuild49
-rwxr-xr-xapp-admin/eselect-php/files/php-fpm-r1.init50
3 files changed, 106 insertions, 1 deletions
diff --git a/app-admin/eselect-php/ChangeLog b/app-admin/eselect-php/ChangeLog
index 5bbc1b4b8159..56d888595279 100644
--- a/app-admin/eselect-php/ChangeLog
+++ b/app-admin/eselect-php/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/eselect-php
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-php/ChangeLog,v 1.55 2013/07/28 19:24:57 olemarkus Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-php/ChangeLog,v 1.56 2013/07/30 10:10:09 olemarkus Exp $
+
+*eselect-php-0.7.1-r2 (30 Jul 2013)
+
+ 30 Jul 2013; Ole Markus With <olemarkus@gentoo.org>
+ +eselect-php-0.7.1-r2.ebuild, +files/php-fpm-r1.init:
+ Fix fpm restart issue
28 Jul 2013; Ole Markus With <olemarkus@gentoo.org> eselect-php-0.6.2.ebuild,
files/php-fpm.conf:
diff --git a/app-admin/eselect-php/eselect-php-0.7.1-r2.ebuild b/app-admin/eselect-php/eselect-php-0.7.1-r2.ebuild
new file mode 100644
index 000000000000..e754669c2b8e
--- /dev/null
+++ b/app-admin/eselect-php/eselect-php-0.7.1-r2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-php/eselect-php-0.7.1-r2.ebuild,v 1.1 2013/07/30 10:10:09 olemarkus Exp $
+
+EAPI=5
+
+inherit depend.apache systemd
+
+DESCRIPTION="PHP eselect module"
+HOMEPAGE="http://www.gentoo.org"
+SRC_URI="http://dev.gentoo.org/~olemarkus/eselect-php/eselect-php-${PV}.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="fpm apache2"
+
+DEPEND=">=app-admin/eselect-1.2.4
+ !<dev-lang/php-5.3.23-r1:5.3
+ !<dev-lang/php-5.4.13-r1:5.4
+ !<dev-lang/php-5.5.0_beta1-r2:5.5
+ "
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+want_apache
+
+src_install() {
+ mv eselect-php-${PV} php.eselect
+ insinto /usr/share/eselect/modules/
+ doins php.eselect
+
+ if use apache2 ; then
+ insinto "${APACHE_MODULES_CONFDIR#${EPREFIX}}"
+ newins "${FILESDIR}/70_mod_php5.conf-apache2" \
+ "70_mod_php5.conf"
+ fi
+
+ if use fpm ; then
+ dodir "/etc/init.d"
+ insinto "/etc/init.d"
+ newinitd "${FILESDIR}/php-fpm-r1.init" "php-fpm"
+ systemd_newunit "${FILESDIR}/php-fpm_at.service" "php-fpm@.service"
+ systemd_dotmpfilesd "${FILESDIR}/php-fpm.conf"
+ exeinto /usr/libexec
+ doexe "${FILESDIR}/php-fpm-launcher"
+ fi
+}
diff --git a/app-admin/eselect-php/files/php-fpm-r1.init b/app-admin/eselect-php/files/php-fpm-r1.init
new file mode 100755
index 000000000000..6cc26acc3c36
--- /dev/null
+++ b/app-admin/eselect-php/files/php-fpm-r1.init
@@ -0,0 +1,50 @@
+#!/sbin/runscript
+
+set_phpvars() {
+ PHPSLOT=${SVCNAME#php-fpm-}
+ PHP_FPM_PID="/run/php-fpm-${PHPSLOT}.pid"
+ if [ ${PHPSLOT} = 'php-fpm' ] ; then
+ PHPSLOT="$(eselect php show fpm)"
+ PHP_FPM_PID="/run/php-fpm.pid"
+ fi
+
+ PHP_FPM_CONF="/etc/php/fpm-${PHPSLOT}/php-fpm.conf"
+}
+
+extra_commands="depend"
+extra_started_commands="reload"
+
+depend() {
+ need net
+ use apache2 lighttpd nginx
+}
+
+start() {
+ ebegin "Starting PHP FastCGI Process Manager"
+ set_phpvars
+ start-stop-daemon --start --pidfile ${PHP_FPM_PID} --exec \
+ /usr/lib/${PHPSLOT}/bin/php-fpm -- -y "${PHP_FPM_CONF}" -g "${PHP_FPM_PID}"
+ local i=0
+ local timeout=5
+ while [ ! -f ${PHP_FPM_PID} ] && [ $i -le $timeout ]; do
+ sleep 1
+ i=$(($i + 1))
+ done
+
+ [ $timeout -gt $i ]
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping PHP FastCGI Process Manager"
+ set_phpvars
+ start-stop-daemon --signal QUIT --stop --exec /usr/lib/${PHPSLOT}/bin/php-fpm --pidfile ${PHP_FPM_PID}
+ eend $?
+}
+
+reload() {
+ ebegin "Reloading PHP FastCGI Process Manager"
+ set_phpvars
+ [ -f ${PHP_FPM_PID} ] && kill -USR2 $(cat ${PHP_FPM_PID})
+ eend $?
+}