summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2007-03-07 21:16:11 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2007-03-07 21:16:11 +0000
commitdeb4c68e2045619f87e4db70eadf16966b8a31c4 (patch)
tree98ba0a3d0044749fd1d1b22e0ce8663e59b9c2cb /app-admin/eselect-opengl
parentx86 stable wrt bug 169819, thanks to Ticho (diff)
downloadgentoo-2-deb4c68e2045619f87e4db70eadf16966b8a31c4.tar.gz
gentoo-2-deb4c68e2045619f87e4db70eadf16966b8a31c4.tar.bz2
gentoo-2-deb4c68e2045619f87e4db70eadf16966b8a31c4.zip
Change all instances of [ to [[.
(Portage version: 2.1.2.1)
Diffstat (limited to 'app-admin/eselect-opengl')
-rw-r--r--app-admin/eselect-opengl/ChangeLog7
-rw-r--r--app-admin/eselect-opengl/eselect-opengl-1.0.3.ebuild16
-rw-r--r--app-admin/eselect-opengl/eselect-opengl-1.0.4.ebuild16
-rw-r--r--app-admin/eselect-opengl/eselect-opengl-1.0.5.ebuild14
4 files changed, 32 insertions, 21 deletions
diff --git a/app-admin/eselect-opengl/ChangeLog b/app-admin/eselect-opengl/ChangeLog
index d2e71c38676e..44a850c96fce 100644
--- a/app-admin/eselect-opengl/ChangeLog
+++ b/app-admin/eselect-opengl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/eselect-opengl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/ChangeLog,v 1.27 2007/02/07 14:47:28 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/ChangeLog,v 1.28 2007/03/07 21:16:11 wolf31o2 Exp $
+
+ 07 Mar 2007; Chris Gianelloni <wolf31o2@gentoo.org>
+ eselect-opengl-1.0.3.ebuild, eselect-opengl-1.0.4.ebuild,
+ eselect-opengl-1.0.5.ebuild:
+ Change all instances of [ to [[.
07 Feb 2007; Simon Stelling <blubb@gentoo.org>
eselect-opengl-1.0.5.ebuild:
diff --git a/app-admin/eselect-opengl/eselect-opengl-1.0.3.ebuild b/app-admin/eselect-opengl/eselect-opengl-1.0.3.ebuild
index 3d39a3cb38c0..0d8d77c58781 100644
--- a/app-admin/eselect-opengl/eselect-opengl-1.0.3.ebuild
+++ b/app-admin/eselect-opengl/eselect-opengl-1.0.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/eselect-opengl-1.0.3.ebuild,v 1.12 2006/10/08 13:11:41 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/eselect-opengl-1.0.3.ebuild,v 1.13 2007/03/07 21:16:11 wolf31o2 Exp $
inherit multilib
@@ -43,15 +43,17 @@ src_unpack() {
pkg_preinst() {
# It needs to be before 04multilib
- [ -f "${ROOT}/etc/env.d/09opengl" ] && mv ${ROOT}/etc/env.d/09opengl ${ROOT}/etc/env.d/03opengl
+ [[ -f "${ROOT}/etc/env.d/09opengl" ]] && mv ${ROOT}/etc/env.d/09opengl ${ROOT}/etc/env.d/03opengl
OABI="${ABI}"
for ABI in $(get_install_abis); do
- if [ -e "${ROOT}/usr/$(get_libdir)/opengl/xorg-x11/lib/libMesaGL.so" ]; then
- einfo "Removing libMesaGL.so from xorg-x11 profile. See bug #47598."
+ if [[ -e "${ROOT}/usr/$(get_libdir)/opengl/xorg-x11/lib/libMesaGL.so" ]]
+ then
+ einfo "Removing libMesaGL.so from xorg-x11 profile. See bug #47598."
rm -f ${ROOT}/usr/$(get_libdir)/opengl/xorg-x11/lib/libMesaGL.so
fi
- if [ -e "${ROOT}/usr/$(get_libdir)/libMesaGL.so" ]; then
+ if [[ -e "${ROOT}/usr/$(get_libdir)/libMesaGL.so" ]]
+ then
einfo "Removing libMesaGL.so from /usr/$(get_libdir). See bug #47598."
rm -f ${ROOT}/usr/$(get_libdir)/libMesaGL.so
fi
@@ -77,7 +79,7 @@ src_install() {
# MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
local MLTEST=$(type dyn_unpack)
- if has_multilib_profile && [ "${MLTEST/set_abi}" = "${MLTEST}" ]; then
+ if has_multilib_profile && [[ "${MLTEST/set_abi}" = "${MLTEST}" ]] ; then
OABI="${ABI}"
for ABI in $(get_install_abis); do
# Install default glext.h
diff --git a/app-admin/eselect-opengl/eselect-opengl-1.0.4.ebuild b/app-admin/eselect-opengl/eselect-opengl-1.0.4.ebuild
index 981b7ab43fcb..0ec9cb4b65ec 100644
--- a/app-admin/eselect-opengl/eselect-opengl-1.0.4.ebuild
+++ b/app-admin/eselect-opengl/eselect-opengl-1.0.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/eselect-opengl-1.0.4.ebuild,v 1.3 2006/12/05 15:02:09 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/eselect-opengl-1.0.4.ebuild,v 1.4 2007/03/07 21:16:11 wolf31o2 Exp $
inherit multilib
@@ -42,15 +42,17 @@ src_unpack() {
pkg_preinst() {
# It needs to be before 04multilib
- [ -f "${ROOT}/etc/env.d/09opengl" ] && mv ${ROOT}/etc/env.d/09opengl ${ROOT}/etc/env.d/03opengl
+ [[ -f "${ROOT}/etc/env.d/09opengl" ]] && mv ${ROOT}/etc/env.d/09opengl ${ROOT}/etc/env.d/03opengl
OABI="${ABI}"
for ABI in $(get_install_abis); do
- if [ -e "${ROOT}/usr/$(get_libdir)/opengl/xorg-x11/lib/libMesaGL.so" ]; then
- einfo "Removing libMesaGL.so from xorg-x11 profile. See bug #47598."
+ if [[ -e "${ROOT}/usr/$(get_libdir)/opengl/xorg-x11/lib/libMesaGL.so" ]]
+ then
+ einfo "Removing libMesaGL.so from xorg-x11 profile. See bug #47598."
rm -f ${ROOT}/usr/$(get_libdir)/opengl/xorg-x11/lib/libMesaGL.so
fi
- if [ -e "${ROOT}/usr/$(get_libdir)/libMesaGL.so" ]; then
+ if [[ -e "${ROOT}/usr/$(get_libdir)/libMesaGL.so" ]]
+ then
einfo "Removing libMesaGL.so from /usr/$(get_libdir). See bug #47598."
rm -f ${ROOT}/usr/$(get_libdir)/libMesaGL.so
fi
@@ -76,7 +78,7 @@ src_install() {
# MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
local MLTEST=$(type dyn_unpack)
- if has_multilib_profile && [ "${MLTEST/set_abi}" = "${MLTEST}" ]; then
+ if has_multilib_profile && [[ "${MLTEST/set_abi}" = "${MLTEST}" ]] ; then
OABI="${ABI}"
for ABI in $(get_install_abis); do
# Install default glext.h
diff --git a/app-admin/eselect-opengl/eselect-opengl-1.0.5.ebuild b/app-admin/eselect-opengl/eselect-opengl-1.0.5.ebuild
index a7c86bc3252a..317256438823 100644
--- a/app-admin/eselect-opengl/eselect-opengl-1.0.5.ebuild
+++ b/app-admin/eselect-opengl/eselect-opengl-1.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/eselect-opengl-1.0.5.ebuild,v 1.11 2007/02/07 14:47:28 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/eselect-opengl/eselect-opengl-1.0.5.ebuild,v 1.12 2007/03/07 21:16:11 wolf31o2 Exp $
inherit multilib
@@ -39,15 +39,17 @@ src_unpack() {
pkg_preinst() {
# It needs to be before 04multilib
- [ -f "${ROOT}/etc/env.d/09opengl" ] && mv ${ROOT}/etc/env.d/09opengl ${ROOT}/etc/env.d/03opengl
+ [[ -f "${ROOT}/etc/env.d/09opengl" ]] && mv ${ROOT}/etc/env.d/09opengl ${ROOT}/etc/env.d/03opengl
OABI="${ABI}"
for ABI in $(get_install_abis); do
- if [ -e "${ROOT}/usr/$(get_libdir)/opengl/xorg-x11/lib/libMesaGL.so" ]; then
- einfo "Removing libMesaGL.so from xorg-x11 profile. See bug #47598."
+ if [[ -e "${ROOT}/usr/$(get_libdir)/opengl/xorg-x11/lib/libMesaGL.so" ]]
+ then
+ einfo "Removing libMesaGL.so from xorg-x11 profile. See bug #47598."
rm -f ${ROOT}/usr/$(get_libdir)/opengl/xorg-x11/lib/libMesaGL.so
fi
- if [ -e "${ROOT}/usr/$(get_libdir)/libMesaGL.so" ]; then
+ if [[ -e "${ROOT}/usr/$(get_libdir)/libMesaGL.so" ]]
+ then
einfo "Removing libMesaGL.so from /usr/$(get_libdir). See bug #47598."
rm -f ${ROOT}/usr/$(get_libdir)/libMesaGL.so
fi
@@ -73,7 +75,7 @@ src_install() {
# MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
local MLTEST=$(type dyn_unpack)
- if has_multilib_profile && [ "${MLTEST/set_abi}" = "${MLTEST}" ]; then
+ if has_multilib_profile && [[ "${MLTEST/set_abi}" = "${MLTEST}" ]] ; then
OABI="${ABI}"
for ABI in $(get_install_abis); do
# Install default glext.h