summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-10-30 21:23:08 +0000
committerMike Frysinger <vapier@gentoo.org>2014-10-30 21:23:08 +0000
commitd345db2bda04ae2f02eee4eb32cf1726611c49aa (patch)
tree2a0f277fa8ccceb37aa1ca104f3a237a1b08a75d
parentSource /etc/conf.d/gpsd in hotplug rules #511584 by Mark Wagner. (diff)
downloadgentoo-2-d345db2bda04ae2f02eee4eb32cf1726611c49aa.tar.gz
gentoo-2-d345db2bda04ae2f02eee4eb32cf1726611c49aa.tar.bz2
gentoo-2-d345db2bda04ae2f02eee4eb32cf1726611c49aa.zip
Add fix from upstream for building w/nmea driver disabled #493022 by n1ghtmare.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
-rw-r--r--sci-geosciences/gpsd/ChangeLog7
-rw-r--r--sci-geosciences/gpsd/files/gpsd-3.10-nmea-disabled.patch54
-rw-r--r--sci-geosciences/gpsd/gpsd-3.10.ebuild3
3 files changed, 62 insertions, 2 deletions
diff --git a/sci-geosciences/gpsd/ChangeLog b/sci-geosciences/gpsd/ChangeLog
index c70a01d075b4..3be1dd58c004 100644
--- a/sci-geosciences/gpsd/ChangeLog
+++ b/sci-geosciences/gpsd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-geosciences/gpsd
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.123 2014/10/30 21:20:36 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/ChangeLog,v 1.124 2014/10/30 21:23:08 vapier Exp $
+
+ 30 Oct 2014; Mike Frysinger <vapier@gentoo.org>
+ +files/gpsd-3.10-nmea-disabled.patch, gpsd-3.10.ebuild:
+ Add fix from upstream for building w/nmea driver disabled #493022 by
+ n1ghtmare.
30 Oct 2014; Mike Frysinger <vapier@gentoo.org>
+files/gpsd-3.11-hotplug-config.patch, files/gpsd.init-2, gpsd-9999.ebuild:
diff --git a/sci-geosciences/gpsd/files/gpsd-3.10-nmea-disabled.patch b/sci-geosciences/gpsd/files/gpsd-3.10-nmea-disabled.patch
new file mode 100644
index 000000000000..e87eff8a5644
--- /dev/null
+++ b/sci-geosciences/gpsd/files/gpsd-3.10-nmea-disabled.patch
@@ -0,0 +1,54 @@
+https://bugs.gentoo.org/493022
+
+From c31095e1562494a74d56b46fcc01541d1444cd5c Mon Sep 17 00:00:00 2001
+From: Simon Dawson <spdawson@gmail.com>
+Date: Sun, 8 Dec 2013 10:31:25 +0000
+Subject: [PATCH] gpsmon: fix build when nmea is false
+
+When nmea is False and ncurses support is enabled, the build fails as
+follows.
+
+gpsmon.o: In function `gpsmon_hook':
+gpsmon.c:(.text+0x974): undefined reference to `driver_nmea0183'
+collect2: error: ld returned 1 exit status
+scons: *** [gpsmon] Error 1
+scons: building terminated because of errors.
+
+The problem appears to be a failure to protect use of the driver_nmea0183
+variable with appropriate #ifdef guards.
+
+Signed-off-by: Simon Dawson <spdawson@gmail.com>
+Signed-off-by: Eric S. Raymond <esr@thyrsus.com>
+---
+ gpsmon.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/gpsmon.c b/gpsmon.c
+index de1f14b..b030979 100644
+--- a/gpsmon.c
++++ b/gpsmon.c
+@@ -36,7 +36,9 @@ extern struct monitor_object_t garmin_mmt, garmin_bin_ser_mmt;
+ extern struct monitor_object_t italk_mmt, ubx_mmt, superstar2_mmt;
+ extern struct monitor_object_t fv18_mmt, gpsclock_mmt, mtk3301_mmt;
+ extern struct monitor_object_t oncore_mmt, tnt_mmt, aivdm_mmt;
++#ifdef NMEA_ENABLE
+ extern const struct gps_type_t driver_nmea0183;
++#endif /* NMEA_ENABLE */
+
+ /* These are public */
+ struct gps_device_t session;
+@@ -477,9 +479,11 @@ static void select_packet_monitor(struct gps_device_t *device)
+ */
+ if (device->packet.type != last_type) {
+ const struct gps_type_t *active_type = device->device_type;
++#ifdef NMEA_ENABLE
+ if (device->packet.type == NMEA_PACKET
+ && ((device->device_type->flags & DRIVER_STICKY) != 0))
+ active_type = &driver_nmea0183;
++#endif /* NMEA_ENABLE */
+ if (!switch_type(active_type))
+ longjmp(terminate, TERM_DRIVER_SWITCH);
+ else {
+--
+2.1.2
+
diff --git a/sci-geosciences/gpsd/gpsd-3.10.ebuild b/sci-geosciences/gpsd/gpsd-3.10.ebuild
index 35be2a4f066e..97981f2904dd 100644
--- a/sci-geosciences/gpsd/gpsd-3.10.ebuild
+++ b/sci-geosciences/gpsd/gpsd-3.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-3.10.ebuild,v 1.2 2014/07/30 19:41:46 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-geosciences/gpsd/gpsd-3.10.ebuild,v 1.3 2014/10/30 21:23:08 vapier Exp $
EAPI="5"
@@ -73,6 +73,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-3.10-rpath.patch
epatch "${FILESDIR}"/${PN}-3.10-dbus.patch
epatch "${FILESDIR}"/${PN}-3.10-udev-install.patch
+ epatch "${FILESDIR}"/${PN}-3.10-nmea-disabled.patch #493022
# Avoid useless -L paths to the install dir
sed -i \