summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2013-09-18 10:11:32 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2013-09-18 10:11:32 +0000
commit167437185740a5111dad2db6a41932e24d29c9cd (patch)
tree21f69d519edc4d2d75d1ca119523c63dcafc77ee
parentsys-fs/cachefilesd: Install systemd unit (diff)
downloadgentoo-2-167437185740a5111dad2db6a41932e24d29c9cd.tar.gz
gentoo-2-167437185740a5111dad2db6a41932e24d29c9cd.tar.bz2
gentoo-2-167437185740a5111dad2db6a41932e24d29c9cd.zip
Version bump
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key 0x5D21B852895192F9)
-rw-r--r--sci-libs/hdf5/ChangeLog8
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.11-implicits.patch45
-rw-r--r--sci-libs/hdf5/hdf5-1.8.11.ebuild108
3 files changed, 160 insertions, 1 deletions
diff --git a/sci-libs/hdf5/ChangeLog b/sci-libs/hdf5/ChangeLog
index da38fc586aef..3832b5b9f1e7 100644
--- a/sci-libs/hdf5/ChangeLog
+++ b/sci-libs/hdf5/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/hdf5
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.115 2013/07/18 17:46:07 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.116 2013/09/18 10:11:32 xarthisius Exp $
+
+*hdf5-1.8.11 (18 Sep 2013)
+
+ 18 Sep 2013; Kacper Kowalik <xarthisius@gentoo.org>
+ +files/hdf5-1.8.11-implicits.patch, +hdf5-1.8.11.ebuild:
+ Version bump
18 Jul 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
hdf5-1.8.10_p1.ebuild:
diff --git a/sci-libs/hdf5/files/hdf5-1.8.11-implicits.patch b/sci-libs/hdf5/files/hdf5-1.8.11-implicits.patch
new file mode 100644
index 000000000000..478557013596
--- /dev/null
+++ b/sci-libs/hdf5/files/hdf5-1.8.11-implicits.patch
@@ -0,0 +1,45 @@
+--- a/hl/src/H5LTanalyze.c
++++ b/hl/src/H5LTanalyze.c
+@@ -49,6 +49,7 @@
+ #define YY_FLEX_MINOR_VERSION 5
+
+ #include <stdio.h>
++#include "H5public.h"
+ #ifdef H5_HAVE_UNISTD_H
+ #include <unistd.h>
+ #endif
+--- a/test/cache_common.h
++++ b/test/cache_common.h
+@@ -702,5 +702,8 @@ void validate_mdc_config(hid_t file_id,
+ hbool_t compare_init,
+ int test_num);
+
++hbool_t resize_configs_are_equal(const H5C_auto_size_ctl_t *a,
++ const H5C_auto_size_ctl_t *b,
++ hbool_t compare_init);
+ #endif /* _CACHE_COMMON_H */
+
+--- a/testpar/t_span_tree.c
++++ b/testpar/t_span_tree.c
+@@ -37,6 +37,9 @@
+ #include "hdf5.h"
+ #include "H5private.h"
+ #include "testphdf5.h"
++#define H5S_PACKAGE
++#define H5S_TESTING
++#include "H5Spkg.h"
+
+
+ static void coll_write_test(int chunk_factor);
+--- a/configure.ac
++++ b/configure.ac
+@@ -1504,6 +1504,9 @@ case "$host_cpu-$host_vendor-$host_os" in
+ ## however, we do not do this since it breaks the big test on some
+ ## older platforms.
+ AM_CPPFLAGS="-D_BSD_SOURCE $AM_CPPFLAGS"
++
++ ## _GNU_SOURCE is needed for vasprintf
++ AM_CPPFLAGS="-D_GNU_SOURCE $AM_CPPFLAGS"
+ ;;
+ esac
+
diff --git a/sci-libs/hdf5/hdf5-1.8.11.ebuild b/sci-libs/hdf5/hdf5-1.8.11.ebuild
new file mode 100644
index 000000000000..306c29db4aae
--- /dev/null
+++ b/sci-libs/hdf5/hdf5-1.8.11.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.11.ebuild,v 1.1 2013/09/18 10:11:32 xarthisius Exp $
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+MY_P=${PN}-${PV/_p/-patch}
+
+inherit autotools eutils fortran-2 flag-o-matic toolchain-funcs multilib
+
+DESCRIPTION="General purpose library and file format for storing scientific data"
+HOMEPAGE="http://www.hdfgroup.org/HDF5/"
+SRC_URI="http://www.hdfgroup.org/ftp/HDF5/releases/${MY_P}/src/${MY_P}.tar.bz2"
+
+LICENSE="NCSA-HDF"
+SLOT="0/${PV%%_p*}"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="cxx debug examples fortran fortran2003 mpi static-libs szip threads zlib"
+
+REQUIRED_USE="
+ cxx? ( !mpi ) mpi? ( !cxx )
+ threads? ( !cxx !mpi !fortran )
+ fortran2003? ( fortran )"
+
+RDEPEND="
+ mpi? ( virtual/mpi[romio] )
+ szip? ( >=sci-libs/szip-2.1 )
+ zlib? ( sys-libs/zlib )"
+
+DEPEND="${RDEPEND}
+ sys-devel/libtool:2
+ >=sys-devel/autoconf-2.69"
+
+pkg_setup() {
+ tc-export CXX CC AR # workaround for bug 285148
+ if use fortran; then
+ use fortran2003 && FORTRAN_STANDARD=2003
+ fortran-2_pkg_setup
+ fi
+ if use mpi; then
+ if has_version 'sci-libs/hdf5[-mpi]'; then
+ ewarn "Installing hdf5 with mpi enabled with a previous hdf5 with mpi disabled may fail."
+ ewarn "Try to uninstall the current hdf5 prior to enabling mpi support."
+ fi
+ export CC=mpicc
+ use fortran && export FC=mpif90
+ elif has_version 'sci-libs/hdf5[mpi]'; then
+ ewarn "Installing hdf5 with mpi disabled while having hdf5 installed with mpi enabled may fail."
+ ewarn "Try to uninstall the current hdf5 prior to disabling mpi support."
+ fi
+}
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.8.10-buildsystem.patch \
+ "${FILESDIR}"/${PN}-1.8.8-array_bounds.patch \
+ "${FILESDIR}"/${PN}-1.8.9-static_libgfortran.patch \
+ "${FILESDIR}"/${PN}-1.8.9-mpicxx.patch \
+ "${FILESDIR}"/${P}-implicits.patch \
+ "${FILESDIR}"/${PN}-1.8.10_p1-comments.patch
+ # respect gentoo examples directory
+ sed \
+ -e "s:hdf5_examples:doc/${PF}/examples:g" \
+ -i $(find . -name Makefile.am) $(find . -name "run*.sh.in") || die
+ sed \
+ -e '/docdir/d' \
+ -i config/commence.am || die
+ if ! use examples; then
+ sed -e '/^install:/ s/install-examples//' \
+ -i Makefile.am || die #409091
+ fi
+ eautoreconf
+ # enable shared libs by default for h5cc config utility
+ sed -i -e "s/SHLIB:-no/SHLIB:-yes/g" tools/misc/h5cc.in || die
+ # bug #419677
+ use prefix && \
+ append-ldflags -Wl,-rpath,"${EPREFIX}"/usr/$(get_libdir) \
+ -Wl,-rpath,"${EPREFIX}"/$(get_libdir)
+}
+
+src_configure() {
+ econf \
+ --enable-production \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --enable-deprecated-symbols \
+ --enable-shared \
+ --disable-silent-rules \
+ $(use_enable prefix sharedlib-rpath) \
+ $(use_enable static-libs static) \
+ $(use_enable debug debug all) \
+ $(use_enable debug codestack) \
+ $(use_enable cxx) \
+ $(use_enable fortran) \
+ $(use_enable fortran2003) \
+ $(use_enable mpi parallel) \
+ $(use_enable threads threadsafe) \
+ $(use_with szip szlib) \
+ $(use_with threads pthread) \
+ $(use_with zlib) \
+ ${myconf}
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+}