summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2005-07-18 17:54:14 +0000
committerThomas Matthijs <axxo@gentoo.org>2005-07-18 17:54:14 +0000
commit13d13238c9a22e140bd217c9173462f8955fa4d4 (patch)
tree8fb453a26becf87f264c2b5979a359e6877227f8
parentKeyworded ~sparc (diff)
downloadgentoo-2-13d13238c9a22e140bd217c9173462f8955fa4d4.tar.gz
gentoo-2-13d13238c9a22e140bd217c9173462f8955fa4d4.tar.bz2
gentoo-2-13d13238c9a22e140bd217c9173462f8955fa4d4.zip
dep/style fixes
(Portage version: 2.0.51.22-r1)
-rw-r--r--dev-java/swt/files/digest-swt-3.1_pre5-r12
-rw-r--r--dev-java/swt/files/digest-swt-3.1_pre73
-rw-r--r--dev-java/swt/swt-3.1.ebuild38
-rw-r--r--dev-java/swt/swt-3.1_pre5-r1.ebuild176
-rw-r--r--dev-java/swt/swt-3.1_pre7.ebuild153
5 files changed, 19 insertions, 353 deletions
diff --git a/dev-java/swt/files/digest-swt-3.1_pre5-r1 b/dev-java/swt/files/digest-swt-3.1_pre5-r1
deleted file mode 100644
index 2543c56e1ad7..000000000000
--- a/dev-java/swt/files/digest-swt-3.1_pre5-r1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 5d8fa0f4c4f44e94bbd80227b86669c1 swt-3.1M5a-linux-gtk.zip 2544679
-MD5 2ec8125407ce4be940c3b9ce5ed1e5cd swt-3.1M5a-linux-gtk-x86_64.zip 2570843
diff --git a/dev-java/swt/files/digest-swt-3.1_pre7 b/dev-java/swt/files/digest-swt-3.1_pre7
deleted file mode 100644
index ff365e81bf6e..000000000000
--- a/dev-java/swt/files/digest-swt-3.1_pre7
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 e70470f5f6d21f7b08e22d7692ed506e swt-3.1M7-gtk-linux-x86.zip 2497131
-MD5 3ec7e455280e58c3ce6b7186bcb76789 swt-3.1M7-gtk-linux-x86_64.zip 2526816
-MD5 ef0c5f1e42180c73ec8943eb676d4529 swt-3.1M7-gtk-linux-ppc.zip 2476242
diff --git a/dev-java/swt/swt-3.1.ebuild b/dev-java/swt/swt-3.1.ebuild
index 541e162368aa..9b81ea0e193e 100644
--- a/dev-java/swt/swt-3.1.ebuild
+++ b/dev-java/swt/swt-3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.1.ebuild,v 1.8 2005/07/06 03:04:23 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.1.ebuild,v 1.9 2005/07/18 17:54:14 axxo Exp $
inherit eutils java-pkg
@@ -18,10 +18,6 @@ LICENSE="CPL-1.0 LGPL-2.1 MPL-1.1"
KEYWORDS="~x86 ~amd64 ~ppc"
IUSE="accessibility cairo firefox gnome mozilla"
-DEPEND="${RDEPEND}
- >=virtual/jdk-1.4
- dev-java/ant-core
- app-arch/unzip"
RDEPEND=">=virtual/jre-1.4
mozilla? (
firefox? ( >=www-client/mozilla-firefox-1.0.3 )
@@ -29,6 +25,10 @@ RDEPEND=">=virtual/jre-1.4
)
gnome? ( =gnome-base/gnome-vfs-2* =gnome-base/libgnomeui-2* )
cairo? ( >=x11-libs/cairo-0.3.0 )"
+DEPEND=">=virtual/jdk-1.4
+ ${RDEPEND}
+ dev-java/ant-core
+ app-arch/unzip"
S=${WORKDIR}
@@ -56,14 +56,14 @@ src_unpack() {
fi
# Clean up the directory structure
- for f in $(ls) ; do
+ for f in *; do
if [[ "${f}" != "src.zip" ]] ; then
rm -rf ${f}
fi
done
# Unpack the sources
- einfo "Unpacking src.zip to ${S}"
+ echo "Unpacking src.zip to ${S}"
unzip src.zip &> /dev/null || die "Unable to extract sources"
# Cleanup the redirtied directory structure
@@ -97,19 +97,19 @@ src_compile() {
# Fix the pointer size for AMD64
[[ ${ARCH} == 'amd64' ]] && export SWT_PTR_CFLAGS=-DSWT_PTR_SIZE_64
- einfo "Building AWT library"
+ echo "Building AWT library"
emake -f make_linux.mak make_awt || die "Failed to build AWT support"
- einfo "Building SWT library"
+ echo "Building SWT library"
emake -f make_linux.mak make_swt || die "Failed to build SWT support"
if use accessibility ; then
- einfo "Building JAVA-AT-SPI bridge"
+ echo "Building JAVA-AT-SPI bridge"
emake -f make_linux.mak make_atk || die "Failed to build ATK support"
fi
if use gnome ; then
- einfo "Building GNOME VFS support"
+ echo "Building GNOME VFS support"
emake -f make_linux.mak make_gnome || die "Failed to build GNOME VFS support"
fi
@@ -130,37 +130,37 @@ src_compile() {
-I${GECKO_SDK}/include/embedstring -I${GECKO_SDK}/include/embedstring/include"
export GECKO_LIBS="-L${GECKO_SDK} -lgtkembedmoz"
- einfo "Building the Mozilla component"
+ echo "Building the Mozilla component"
emake -f make_linux.mak make_mozilla || die "Failed to build Mozilla support"
fi
if use cairo ; then
- einfo "Building CAIRO support"
+ echo "Building CAIRO support"
emake -f make_linux.mak make_cairo || die "Unable to build CAIRO support"
fi
- einfo "Building JNI libraries"
+ echo "Building JNI libraries"
ant compile || die "Failed to compile JNI interfaces"
- einfo "Creating missing files"
+ echo "Creating missing files"
echo "version 3.138" > ${S}/build/version.txt
cp ${FILESDIR}/SWTMessages.properties ${S}/build/org/eclipse/swt/internal/
- einfo "Packing JNI libraries"
+ echo "Packing JNI libraries"
ant jar || die "Failed to create JNI jar"
}
src_install() {
- java-pkg_dojar swt.jar || die "Unable to install SWT Java interfaces"
+ java-pkg_dojar swt.jar
java-pkg_sointo /usr/lib
- java-pkg_doso *.so || die "Unable to install SWT libraries"
+ java-pkg_doso *.so
dohtml about.html
}
pkg_postinst() {
- if [[ $(use_enable cairo) ]] ; then
+ if use cairo; then
ewarn
ewarn "CAIRO Support is experimental! We are not responsible if"
ewarn "enabling support for CAIRO corrupts your Gentoo install,"
diff --git a/dev-java/swt/swt-3.1_pre5-r1.ebuild b/dev-java/swt/swt-3.1_pre5-r1.ebuild
deleted file mode 100644
index 80c0e0066f15..000000000000
--- a/dev-java/swt/swt-3.1_pre5-r1.ebuild
+++ /dev/null
@@ -1,176 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.1_pre5-r1.ebuild,v 1.2 2005/05/24 19:23:53 compnerd Exp $
-
-inherit eutils java-pkg
-
-MY_DMF="S-3.1M5a-200502191500"
-MY_VERSION="3.1M5a"
-
-DESCRIPTION="GTK based SWT Library"
-HOMEPAGE="http://www.eclipse.org/"
-SRC_URI="x86? ( http://download.eclipse.org/downloads/drops/${MY_DMF}/swt-${MY_VERSION}-linux-gtk.zip )
- amd64? ( http://download.eclipse.org/downloads/drops/${MY_DMF}/swt-${MY_VERSION}-linux-gtk-x86_64.zip )"
-
-SLOT="3"
-LICENSE="CPL-1.0 LGPL-2.1 MPL-1.1"
-KEYWORDS="~x86 ~amd64"
-
-IUSE="accessibility cairo firefox gnome mozilla"
-DEPEND="${RDEPEND}
- >=virtual/jdk-1.4
- dev-java/ant-core
- app-arch/unzip"
-RDEPEND=">=virtual/jre-1.4
- mozilla? (
- firefox? ( >=www-client/mozilla-firefox-1.0.3 )
- !firefox? ( >=www-client/mozilla-1.4 )
- )
- gnome? ( =gnome-base/gnome-vfs-2* =gnome-base/libgnomeui-2* )
- cairo? ( >=x11-libs/cairo-0.3.0 )"
-
-S=${WORKDIR}
-
-pkg_setup() {
- if use firefox ; then
- if ! use mozilla ; then
- echo
- ewarn "You must enable the mozilla useflag to build the browser"
- ewarn "component. The firefox flag is used only to determine"
- ewarn "what to build against."
-
- die "Firefox useflag enabled without mozilla support"
- fi
- fi
-}
-
-src_unpack() {
- # Extract based on architecture
- if [[ ${ARCH} == 'x86' ]] ; then
- unpack swt-${MY_VERSION}-linux-gtk.zip
- else
- unpack swt-${MY_VERSION}-linux-gtk-x86_64.zip
- fi
-
- # Clean up the directory structure
- rm -r *.so *.jar
- rm cpl-v10.html lgpl-v21.txt mpl-v11.txt
-
- # We still need to have the JNI interfaces for these
- # use mozilla || rm -f swt-mozillasrc.zip
- # use cairo || rm -f swt-cairosrc.zip
-
- # Unpack the sources
- for i in $(ls *.zip) ; do
- einfo "Unpacking ${i} to ${S}"
- unzip $i &> /dev/null || die "Unable to extract sources"
- done
-
- # Take the XPCOM objects from the library code if we build the Mozilla
- # Component
- if use mozilla ; then
- cp library/xpcom* ${S} || die "Unable to find sources for mozilla component."
- fi
-
- # Copy the cairo sources for compiling the cairo component
- if use cairo ; then
- cp library/cairo* ${S} || die "Unable to find sources for CAIRO component."
- fi
-
- # Replace the build.xml to allow compilation without Eclipse tasks
- cp ${FILESDIR}/build.xml ${S} || die "Unable to update build.xml"
- mkdir ${S}/src && mv ${S}/org ${S}/src || die "Unable to restructure SWT sources"
-}
-
-src_compile() {
- JAVA_HOME=$(java-config -O)
-
- # Identify the AWT path
- if [[ ${ARCH} == 'x86' ]] ; then
- export AWT_LIB_PATH=$JAVA_HOME/jre/lib/i386
- else
- export AWT_LIB_PATH=$JAVA_HOME/jre/lib/amd64
- fi
-
- # Identity the XTEST library location
- export XTEST_LIB_PATH=/usr/X11R6/lib
-
- # Fix the pointer size for AMD64
- [[ ${ARCH} == 'amd64' ]] && export SWT_PTR_CFLAGS=-DSWT_PTR_SIZE_64
-
- # Apply the Cairo patch
- use cairo && epatch ${FILESDIR}/cairo.patch
-
- # Fix the Makefile
- sed -e "s:-I\$(JAVA_HOME)/include\(.*\)$:-I\$(JAVA_HOME)/include -I\$(JAVA_HOME)/include/linux \1:" \
- -e "s:/usr/local:/usr:" \
- -e "s:CAIROCFLAGS = \([^ ]*\) \(.*\)$:CAIROCFLAGS = \1 -I/usr/include/cairo \2:" \
- make_linux.mak > Makefile
-
- einfo "Building AWT library"
- emake make_awt || die "Failed to build AWT support"
-
- einfo "Building SWT library"
- emake make_swt || die "Failed to build SWT support"
-
- if use accessibility ; then
- einfo "Building JAVA-AT-SPI bridge"
- emake make_atk || die "Failed to build ATK support"
- fi
-
- if use gnome ; then
- einfo "Building GNOME VFS support"
- emake make_gnome || die "Failed to build GNOME VFS support"
- fi
-
- if use mozilla ; then
- if use firefox ; then
- GECKO_SDK=/usr/lib/MozillaFirefox
- else
- GECKO_SDK=/usr/lib/mozilla
- fi
-
- export GECKO_INCLUDES="-include ${GECKO_SDK}/include/mozilla-config.h \
- -I${GECKO_SDK}/include \
- -I${GECKO_SDK}/include/java \
- -I${GECKO_SDK}/include/nspr -I${GECKO_SDK}/include/nspr/include \
- -I${GECKO_SDK}/include/xpcom -I${GECKO_SDK}/include/xpcom/include \
- -I${GECKO_SDK}/include/string -I${GECKO_SDK}/include/string/include \
- -I${GECKO_SDK}/include/embed_base -I${GECKO_SDK}/include/embed_base/include \
- -I${GECKO_SDK}/include/embedstring -I${GECKO_SDK}/include/embedstring/include"
- export GECKO_LIBS="-L${GECKO_SDK} -lgtkembedmoz"
-
- einfo "Building the Mozilla component"
- emake make_mozilla || die "Failed to build Mozilla support"
- fi
-
- if use cairo ; then
- einfo "Building CAIRO support"
- emake make_cairo || die "Unable to build CAIRO support"
- fi
-
- einfo "Building JNI libraries"
- local libs="jar_swt-pi jar_swt"
- use cairo && libs="${libs} jar_cairo"
- use mozilla && libs="${libs} jar_mozilla"
- ant ${libs} || die "Failed to create JNI jars"
-}
-
-src_install() {
- java-pkg_dojar *.jar || die "Unable to install SWT Java interfaces"
-
- java-pkg_sointo /usr/lib
- java-pkg_doso *.so || die "Unable to install SWT libraries"
-
- dohtml about.html
-}
-
-pkg_postinst() {
- if use gnome ; then
- ewarn "Changes in the gnome-vfs API may cause warnings with SWT."
- ewarn "Please comment about the warnings at the following location:"
- ewarn "https://bugs.eclipse.org/bugs/show_bug.cgi?id=79268"
-
- ebeep 5
- fi
-}
diff --git a/dev-java/swt/swt-3.1_pre7.ebuild b/dev-java/swt/swt-3.1_pre7.ebuild
deleted file mode 100644
index c19ba039b171..000000000000
--- a/dev-java/swt/swt-3.1_pre7.ebuild
+++ /dev/null
@@ -1,153 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/swt/swt-3.1_pre7.ebuild,v 1.3 2005/07/06 03:19:17 compnerd Exp $
-
-inherit eutils java-pkg
-
-MY_DMF="S-3.1M7-200505131415"
-MY_VERSION="3.1M7"
-
-DESCRIPTION="GTK based SWT Library"
-HOMEPAGE="http://www.eclipse.org/"
-SRC_URI="x86? ( http://download.eclipse.org/downloads/drops/${MY_DMF}/swt-${MY_VERSION}-gtk-linux-x86.zip )
- amd64? ( http://download.eclipse.org/downloads/drops/${MY_DMF}/swt-${MY_VERSION}-gtk-linux-x86_64.zip )
- ppc? ( http://download.eclipse.org/downloads/drops/${MY_DMF}/swt-${MY_VERSION}-gtk-linux-ppc.zip )"
-
-SLOT="3"
-LICENSE="CPL-1.0 LGPL-2.1 MPL-1.1"
-KEYWORDS="~x86 ~amd64 ~ppc"
-
-IUSE="accessibility cairo firefox gnome mozilla"
-DEPEND="${RDEPEND}
- >=virtual/jdk-1.4
- dev-java/ant-core
- app-arch/unzip"
-RDEPEND=">=virtual/jre-1.4
- mozilla? (
- firefox? ( >=www-client/mozilla-firefox-1.0.3 )
- !firefox? ( >=www-client/mozilla-1.4 )
- )
- gnome? ( =gnome-base/gnome-vfs-2* =gnome-base/libgnomeui-2* )
- cairo? ( >=x11-libs/cairo-0.3.0 )"
-
-S=${WORKDIR}
-
-pkg_setup() {
- if use firefox ; then
- if ! use mozilla ; then
- echo
- ewarn "You must enable the mozilla useflag to build the browser"
- ewarn "component. The firefox flag is used only to determine"
- ewarn "what to build against."
-
- die "Firefox useflag enabled without mozilla support"
- fi
- fi
-}
-
-src_unpack() {
- # Extract based on architecture
- if [[ ${ARCH} == 'amd64' ]] ; then
- unpack swt-${MY_VERSION}-gtk-linux-x86_64.zip
- elif [[ ${ARCH} == 'ppc' ]] ; then
- unpack swt-${MY_VERSION}-gtk-linux-ppc.zip
- else
- unpack swt-${MY_VERSION}-gtk-linux-x86.zip
- fi
-
- # Clean up the directory structure
- rm -r *.so swt.jar
- rm -rf about_files/
-
- # Unpack the sources
- einfo "Unpacking src.zip to ${S}"
- unzip src.zip &> /dev/null || die "Unable to extract sources"
-
- # Replace the build.xml to allow compilation without Eclipse tasks
- cp ${FILESDIR}/build-${PV}.xml ${S}/build.xml || die "Unable to update build.xml"
- mkdir ${S}/src && mv ${S}/org ${S}/src || die "Unable to restructure SWT sources"
-}
-
-src_compile() {
- JAVA_HOME=$(java-config -O)
-
- # Identify the AWT path
- if [[ ! -z "$(java-config --java-version | grep 'IBM')" ]] ; then
- export AWT_LIB_PATH=$JAVA_HOME/jre/bin
- else
- if [[ ${ARCH} == 'x86' ]] ; then
- export AWT_LIB_PATH=$JAVA_HOME/jre/lib/i386
- elif [[ ${ARCH} == 'ppc' ]] ; then
- export AWT_LIB_PATH=$JAVA_HOME/jre/bin
- else
- export AWT_LIB_PATH=$JAVA_HOME/jre/lib/amd64
- fi
- fi
-
- # Identity the XTEST library location
- export XTEST_LIB_PATH=/usr/X11R6/lib
-
- # Fix the pointer size for AMD64
- [[ ${ARCH} == 'amd64' ]] && export SWT_PTR_CFLAGS=-DSWT_PTR_SIZE_64
-
- einfo "Building AWT library"
- emake -f make_linux.mak make_awt || die "Failed to build AWT support"
-
- einfo "Building SWT library"
- emake -f make_linux.mak make_swt || die "Failed to build SWT support"
-
- if use accessibility ; then
- einfo "Building JAVA-AT-SPI bridge"
- emake -f make_linux.mak make_atk || die "Failed to build ATK support"
- fi
-
- if use gnome ; then
- einfo "Building GNOME VFS support"
- emake -f make_linux.mak make_gnome || die "Failed to build GNOME VFS support"
- fi
-
- if use mozilla ; then
- if use firefox ; then
- GECKO_SDK=/usr/lib/MozillaFirefox
- else
- GECKO_SDK=/usr/lib/mozilla
- fi
-
- export GECKO_INCLUDES="-include ${GECKO_SDK}/include/mozilla-config.h \
- -I${GECKO_SDK}/include \
- -I${GECKO_SDK}/include/java \
- -I${GECKO_SDK}/include/nspr -I${GECKO_SDK}/include/nspr/include \
- -I${GECKO_SDK}/include/xpcom -I${GECKO_SDK}/include/xpcom/include \
- -I${GECKO_SDK}/include/string -I${GECKO_SDK}/include/string/include \
- -I${GECKO_SDK}/include/embed_base -I${GECKO_SDK}/include/embed_base/include \
- -I${GECKO_SDK}/include/embedstring -I${GECKO_SDK}/include/embedstring/include"
- export GECKO_LIBS="-L${GECKO_SDK} -lgtkembedmoz"
-
- einfo "Building the Mozilla component"
- emake -f make_linux.mak make_mozilla || die "Failed to build Mozilla support"
- fi
-
- if use cairo ; then
- einfo "Building CAIRO support"
- emake -f make_linux.mak make_cairo || die "Unable to build CAIRO support"
- fi
-
- einfo "Building JNI libraries"
- ant compile || die "Failed to compile JNI interfaces"
-
- einfo "Creating missing files"
- echo "version 3.135" > ${S}/build/version.txt
- cp ${FILESDIR}/SWTMessages.properties ${S}/build/org/eclipse/swt/internal/
-
- einfo "Packing JNI libraries"
- ant jar || die "Failed to create JNI jar"
-}
-
-src_install() {
- java-pkg_dojar swt.jar || die "Unable to install SWT Java interfaces"
-
- java-pkg_sointo /usr/lib
- java-pkg_doso *.so || die "Unable to install SWT libraries"
-
- dohtml about.html
-}