summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-10-17 11:01:52 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-10-17 11:01:52 +0000
commit1349e34460cf4dcb5fd0551eefcf8bdac2d54a76 (patch)
tree9f95acd93b5c199ca3211051387f46468ba6d9b7
parentia64/sparc stable wrt #339401 (diff)
downloadgentoo-2-1349e34460cf4dcb5fd0551eefcf8bdac2d54a76.tar.gz
gentoo-2-1349e34460cf4dcb5fd0551eefcf8bdac2d54a76.tar.bz2
gentoo-2-1349e34460cf4dcb5fd0551eefcf8bdac2d54a76.zip
Version bump
(Portage version: 2.2_rc97/cvs/Linux x86_64)
-rw-r--r--x11-libs/libfm/ChangeLog7
-rw-r--r--x11-libs/libfm/libfm-0.1.14.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/x11-libs/libfm/ChangeLog b/x11-libs/libfm/ChangeLog
index 94b8d7fc9bf8..c185cc9b459b 100644
--- a/x11-libs/libfm/ChangeLog
+++ b/x11-libs/libfm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/libfm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/ChangeLog,v 1.15 2010/10/15 00:20:09 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/ChangeLog,v 1.16 2010/10/17 11:01:52 hwoarang Exp $
+
+*libfm-0.1.14 (17 Oct 2010)
+
+ 17 Oct 2010; Markos Chandras <hwoarang@gentoo.org> +libfm-0.1.14.ebuild:
+ Version bump
15 Oct 2010; Markos Chandras <hwoarang@gentoo.org> libfm-9999.ebuild,
metadata.xml:
diff --git a/x11-libs/libfm/libfm-0.1.14.ebuild b/x11-libs/libfm/libfm-0.1.14.ebuild
new file mode 100644
index 000000000000..124c2f2f8591
--- /dev/null
+++ b/x11-libs/libfm/libfm-0.1.14.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/libfm/libfm-0.1.14.ebuild,v 1.1 2010/10/17 11:01:52 hwoarang Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="Library for file management"
+HOMEPAGE="http://pcmanfm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pcmanfm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug demo gnome hal udev udisks"
+
+RDEPEND="dev-libs/glib:2
+ x11-libs/gtk+:2
+ udisks? ( sys-fs/udisks )
+ gnome? ( hal? ( gnome-base/gnome-mount ) )
+ gnome? ( gnome-base/gvfs[hal?,udev?] )
+ >=lxde-base/menu-cache-0.3.2"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ dev-util/gtk-doc
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ for file in app-chooser.ui ask-rename.ui file-prop.ui preferred-apps.ui \
+ progress.ui;do
+ echo "data/ui/${file}" >> po/POTFILES.in
+ done
+ echo "src/udisks/g-udisks-device.c" >> po/POTFILES.in
+ gtkdocize
+ eautoreconf
+ einfo "Running intltoolize ..."
+ intltoolize --force --copy --automake || die
+ strip-linguas -i "${S}/po"
+}
+
+src_configure() {
+ econf --sysconfdir=/etc \
+ $(use_enable debug) \
+ $(use_enable demo) \
+ $(use_enable udisks)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS TODO || die
+}