summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Lutgens <lamer@gentoo.org>2001-07-01 16:32:26 +0000
committerBen Lutgens <lamer@gentoo.org>2001-07-01 16:32:26 +0000
commita50583abe0e34b8a68fefc71d10b044a4f6d5c00 (patch)
tree77966e18704b952156c72556aa46a319bba169f6
parentpolaris from #gentoo did a great job on these I think he's prolly ready to (diff)
downloadgentoo-2-a50583abe0e34b8a68fefc71d10b044a4f6d5c00.tar.gz
gentoo-2-a50583abe0e34b8a68fefc71d10b044a4f6d5c00.tar.bz2
gentoo-2-a50583abe0e34b8a68fefc71d10b044a4f6d5c00.zip
man cvs can be a pain.
-rw-r--r--app-misc/jpilot/files/jpilot-0.99.patch53
-rw-r--r--app-misc/jpilot/jpilot-0.99.ebuild38
-rw-r--r--net-analyzer/iplog/files/digest-iplog-2.2.31
3 files changed, 92 insertions, 0 deletions
diff --git a/app-misc/jpilot/files/jpilot-0.99.patch b/app-misc/jpilot/files/jpilot-0.99.patch
new file mode 100644
index 000000000000..12e009ed8346
--- /dev/null
+++ b/app-misc/jpilot/files/jpilot-0.99.patch
@@ -0,0 +1,53 @@
+--- Makefile.orig Thu Jun 28 23:43:29 2001
++++ Makefile Thu Jun 28 23:47:40 2001
+@@ -224,37 +224,20 @@
+ jpilot-sync jpilot jpilot-dump
+
+ install:
+-# ./install-sh -d $(prefix)/bin/
+- if test -d "$(prefix)/bin" ; then \
+- ./install-sh -s -c -m 555 jpilot $(prefix)/bin/jpilot ; \
+- else \
+- ./install-sh -s -c -m 555 jpilot $(prefix)/jpilot ; \
+- fi
+- if test -d "$(prefix)/bin" ; then \
+- ./install-sh -s -c -m 555 jpilot-sync $(prefix)/bin/jpilot-sync ; \
+- else \
+- ./install-sh -s -c -m 555 jpilot-sync $(prefix)/jpilot-sync ; \
+- fi
+- if test -d "$(prefix)/bin" ; then \
+- ./install-sh -s -c -m 555 jpilot-dump $(prefix)/bin/jpilot-dump ; \
+- else \
+- ./install-sh -s -c -m 555 jpilot-dump $(prefix)/jpilot-dump ; \
+- fi
+- if test -d "$(prefix)/bin" ; then \
+- ./install-sh -s -c -m 555 jpilot-dump $(prefix)/bin/jpilot-upgrade-99 ; \
+- else \
+- ./install-sh -s -c -m 555 jpilot-dump $(prefix)/jpilot-upgrade-99 ; \
+- fi
++ ./install-sh -s -c -m 755 jpilot $(prefix)/bin/jpilot
++ ./install-sh -s -c -m 755 jpilot-sync $(prefix)/bin/jpilot-sync
++ ./install-sh -s -c -m 755 jpilot-dump $(prefix)/bin/jpilot-dump
++ ./install-sh -s -c -m 755 jpilot-dump $(prefix)/bin/jpilot-upgrade-99
+ ./install-sh -d -m 755 $(prefix)/share/jpilot
+- ./install-sh -c -m 755 jpilotrc.blue $(prefix)/share/jpilot
+- ./install-sh -c -m 755 jpilotrc.default $(prefix)/share/jpilot/
+- ./install-sh -c -m 755 jpilotrc.green $(prefix)/share/jpilot/
+- ./install-sh -c -m 755 jpilotrc.purple $(prefix)/share/jpilot/
+- ./install-sh -c -m 755 jpilotrc.steel $(prefix)/share/jpilot/
+- ./install-sh -c -m 755 empty/DatebookDB.pdb $(prefix)/share/jpilot/
+- ./install-sh -c -m 755 empty/AddressDB.pdb $(prefix)/share/jpilot/
+- ./install-sh -c -m 755 empty/ToDoDB.pdb $(prefix)/share/jpilot/
+- ./install-sh -c -m 755 empty/MemoDB.pdb $(prefix)/share/jpilot/
++ ./install-sh -c -m 644 jpilotrc.blue $(prefix)/share/jpilot
++ ./install-sh -c -m 644 jpilotrc.default $(prefix)/share/jpilot/
++ ./install-sh -c -m 644 jpilotrc.green $(prefix)/share/jpilot/
++ ./install-sh -c -m 644 jpilotrc.purple $(prefix)/share/jpilot/
++ ./install-sh -c -m 644 jpilotrc.steel $(prefix)/share/jpilot/
++ ./install-sh -c -m 644 empty/DatebookDB.pdb $(prefix)/share/jpilot/
++ ./install-sh -c -m 644 empty/AddressDB.pdb $(prefix)/share/jpilot/
++ ./install-sh -c -m 644 empty/ToDoDB.pdb $(prefix)/share/jpilot/
++ ./install-sh -c -m 644 empty/MemoDB.pdb $(prefix)/share/jpilot/
+ cd intl; $(MAKE) install
+ cd po; $(MAKE) install
+
diff --git a/app-misc/jpilot/jpilot-0.99.ebuild b/app-misc/jpilot/jpilot-0.99.ebuild
new file mode 100644
index 000000000000..0d1dbe26f406
--- /dev/null
+++ b/app-misc/jpilot/jpilot-0.99.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce A. Locke <blocke@shivan.org>
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Desktop Organizer Software for the Palm Pilot"
+SRC_URI="http://jpilot.org/${P}.tar.gz"
+HOMEPAGE="http://jpilot.org/"
+
+DEPEND=">=x11-libs/gtk+-1.2.0 >=dev-libs/pilot-link-0.9.0"
+
+src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ NLS_OPTION="--disable-nls"
+ fi
+
+ try ./configure --prefix=/usr/X11R6 --host=${CHOST} ${NLS_OPTION}
+
+ # cheap fix?
+ patch -p0 < ${FILESDIR}/${P}.patch
+
+ # make sure we use $CFLAGS
+ mv Makefile Makefile.old
+ sed -e "s/-g -O2/${CFLAGS}/" Makefile.old > Makefile
+
+ try pmake
+}
+
+src_install() {
+
+ make prefix=${D}/usr/X11R6 install
+ dodoc README TODO UPGRADING ABOUT-NLS BUGS\
+ CHANGELOG COPYING CREDITS INSTALL
+ doman docs/*.1
+}
+
diff --git a/net-analyzer/iplog/files/digest-iplog-2.2.3 b/net-analyzer/iplog/files/digest-iplog-2.2.3
new file mode 100644
index 000000000000..2716de2b010e
--- /dev/null
+++ b/net-analyzer/iplog/files/digest-iplog-2.2.3
@@ -0,0 +1 @@
+MD5 de98dd64018ab10ebe36e481cf00b7db iplog-2.2.3.tar.gz