summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-07-03 10:44:43 +0000
committerAchim Gottinger <achim@gentoo.org>2001-07-03 10:44:43 +0000
commit485da46f7cd3421d9f8b4ba1cf3cea6a58bcbfd2 (patch)
treea2d815ff2fa17d656f2498c74b9f1154614aa6f0
parent*** empty log message *** (diff)
downloadgentoo-2-485da46f7cd3421d9f8b4ba1cf3cea6a58bcbfd2.tar.gz
gentoo-2-485da46f7cd3421d9f8b4ba1cf3cea6a58bcbfd2.tar.bz2
gentoo-2-485da46f7cd3421d9f8b4ba1cf3cea6a58bcbfd2.zip
A console based napster client, based on an ebuild sended tomy by bruce
-rw-r--r--media-sound/teknap/files/digest-teknap-1.3f1
-rw-r--r--media-sound/teknap/teknap-1.3f.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/media-sound/teknap/files/digest-teknap-1.3f b/media-sound/teknap/files/digest-teknap-1.3f
new file mode 100644
index 000000000000..ade750cde47e
--- /dev/null
+++ b/media-sound/teknap/files/digest-teknap-1.3f
@@ -0,0 +1 @@
+MD5 95354f338a0fe2db0c6083b7ad212361 TekNap-1.3f.tar.gz
diff --git a/media-sound/teknap/teknap-1.3f.ebuild b/media-sound/teknap/teknap-1.3f.ebuild
new file mode 100644
index 000000000000..8ff4e4481c2e
--- /dev/null
+++ b/media-sound/teknap/teknap-1.3f.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/teknap/teknap-1.3f.ebuild,v 1.1 2001/07/03 10:44:43 achim Exp $
+
+P=TekNap-${PV}
+A=${P}.tar.gz
+S=${WORKDIR}/TekNap
+DESCRIPTION="TekNap is a console Napster/OpenNap client"
+SRC_URI="ftp://ftp.teknap.com/pub/TekNap/${A}"
+HOMEPAGE="http://www.TekNap.com/"
+
+DEPEND="virtual/glibc >=sys-libs/ncurses-5.2
+ gtk? ( >=x11-libs/gtk+-1.2.10 )
+ tcpd? ( sys-apps/tcp-wrappers )
+ xmms? ( media-sound/xmms )"
+
+src_compile() {
+ local myconf
+ if [ "`use gtk`" ] ; then
+ myconf="--with-gtk"
+ fi
+ if [ "`use tcpd`" ] ; then
+ myconf="$myconf --enable-wrap"
+ fi
+ if [ "`use xmms`" ] ; then
+ myconf="$myconf --enable-xmms"
+ fi
+
+ try ./configure --prefix=/usr --mandir=/usr/share/man --enable-cdrom --enable-ipv6 $myconf --host=${CHOST}
+ try make
+
+}
+
+src_install () {
+
+ try make prefix=${D}/usr mandir=${D}/usr/share/man install
+ rm ${D}/usr/bin/TekNap
+ dosym TekNap-1.3f /usr/bin/TekNap
+ dodoc COPYRIGHT README TODO Changelog
+ docinto txt
+ cd doc
+ dodoc *.txt TekNap.faq bugs link-guidelines macosx.notes
+ doman TekNap.1
+}
+