summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-06-12 19:19:13 +0000
committerMike Frysinger <vapier@gentoo.org>2003-06-12 19:19:13 +0000
commitaca7c719192c8f15383a9c2e18b39306908c3c3f (patch)
tree3df6d030bf1465e1eaf3298758b51c1a11768d79
parentglaring ommission (diff)
downloadportage-cvs-aca7c719192c8f15383a9c2e18b39306908c3c3f.tar.gz
portage-cvs-aca7c719192c8f15383a9c2e18b39306908c3c3f.tar.bz2
portage-cvs-aca7c719192c8f15383a9c2e18b39306908c3c3f.zip
sync emerge.1 with emerge --help
-rw-r--r--man/emerge.1276
1 files changed, 161 insertions, 115 deletions
diff --git a/man/emerge.1 b/man/emerge.1
index 6642dfd..4ef924b 100644
--- a/man/emerge.1
+++ b/man/emerge.1
@@ -1,22 +1,22 @@
-.TH "EMERGE" "1" "Feb 2003" "Portage 2.0.47" "Portage"
+.TH "EMERGE" "1" "Jun 2003" "Portage 2.0.48" "Portage"
.SH "NAME"
emerge \- Command\-line interface to the Portage system
.SH "SYNOPSIS"
.TP
-\fBemerge\fR
+.BR emerge
[\fIoptions\fR] [\fIaction\fR] [\fIebuild\fR | \fItbz2file\fR | \fIclass\fR | \fIdependency\fR] ...
.TP
-\fBemerge\fR
+.BR emerge
[\fIoptions\fR] [\fIaction\fR] \fBebuildfile\fR
.TP
-\fBemerge\fR
+.BR emerge
\fBsync\fR | \fBrsync\fR
.TP
-\fBemerge\fR
-\fI\-\-help \-h\fR [\fBsystem\fR | \fBconfig\fR | \fBsync\fR]
+.BR emerge
+\fI--help -h\fR [\fBsystem\fR | \fBconfig\fR | \fBsync\fR]
.TP
-\fBemerge\fR
-\fI\-\-version\fR
+.BR emerge
+\fI--version\fR
.SH "DESCRIPTION"
\fBemerge\fR is the definitive command\-line interface to the Portage
system. It is primarily used for installing packages, and \fBemerge\fR
@@ -32,32 +32,32 @@ packages to install in one of four main ways: an \fIebuild\fR,
a \fItbz2file\fR, a \fIclass\fR, or a \fIdependency\fR.
.LP
.TP
-\fBebuild\fR
+.BR ebuild
An \fIebuild\fR must be, at a minimum, a valid Portage
package directory name without a version or category, such as
\fBportage\fR or \fBpython\fR.
Both categories and version numbers may be used in addition, such
-as \fBsys\-apps/portage\fR or \fB=python\-2.2.1\-r2\fR. \fBemerge\fR
+as \fBsys\-apps/portage\fR or \fB=python\-2.2.1\-r2\fR. \fBemerge\fR
ignores a trailing slash so that filename completion can be used.
The \fIebuild\fR may also be an actual filename, such as
\fB/usr/portage/app\-admin/python/python\-2.2.1\-r2.ebuild\fR.
.TP
-\fBtbz2file\fR
+.BR tbz2file
A \fItbz2file\fR must be a valid .tbz2 created with \fBebuild
-<package>\-<version>.ebuild package\fR or \fBemerge
-\-\-buildpkg [category/]<package>\fR or \fBquickpkg /var/db/pkg/<category>/<package>\fR.
+<package>\-<version>.ebuild package\fR or \fBemerge --buildpkg
+[category/]<package>\fR or \fBquickpkg /var/db/pkg/<category>/<package>\fR.
.TP
-\fBclass\fR
+.BR class
Package classes are a convenient shorthand for large groups of
packages. Two classes are currently supported: \fBsystem\fR
and \fBworld\fR. \fBsystem\fR refers to a set of packages
deemed necessary for your system to run properly. \fBworld\fR
contains all of the packages in \fBsystem\fR, along with any
-other packages listed in \fB/var/cache/edb/world\fR. [See
+other packages listed in \fB/var/cache/edb/world\fR. [See
\fBFILES\fR below for more information.] Note that these
-commands are generally used in conjunction with \fB\-\-update\fR.
+commands are generally used in conjunction with \fB--update\fR.
.TP
-\fBdependency\fR
+.BR dependency
A \fIdependency\fR describes bounds on a package that you wish
to install. For example, \fB>=dev\-lang/python\-2.2.1\-r2\fR
matches the latest available version of Python greater than or equal
@@ -68,16 +68,16 @@ use single\- or double\-quotes around the \fIdependency\fR
to get around escaping problems.
.SH "ACTIONS"
.TP
-\fBNo action\fR
+.BR "No action"
If no action is specified, the action is to merge in the specified
packages, satisfying any dependencies that they may have. The
arguments can be \fIebuilds\fR, \fItbz2s\fR, \fIclasses\fR, or
-\fIdependencies\fR. \fBNote that you need to use the\fR \-\-usepkg
-\fBoption if you want to install a tbz2\fR. The packages are added
+\fIdependencies\fR. \fBNote that you need to use the --usepkg
+option if you want to install a tbz2\fR. The packages are added
to the \fBworld\fR file at the end, so that they are considered for
later updating.
.TP
-\fBclean\fR (\fB\-c\fR)
+.BR "clean " (\fB\-c\fR)
Cleans the system by removing packages that will not effect the
functionality of the system. The arguments can be \fIebuilds\fR,
\fIclasses\fR, or \fIdependencies\fR. For example, \fBemerge
@@ -86,169 +86,211 @@ clean binutils\fR cleans out old versions of binutils;
specific version of Mozilla. This is generally safe to use.
\fBNote that\fR clean \fBdoes not remove unslotted packages.\fR
.TP
-\fBdepclean\fR
+.BR depclean
Determines all packages installed on the system that have no
explicit reason for being there. \fBemerge\fR generates a list
of packages which it expects to be installed by checking the
\fBsystem\fR package list and the \fBworld\fR file. It then
compares that list to the list of packages which are actually
installed; the differences are listed as unnecessary packages
-and are suggested for unmerging. \fBWARNING: Removing some
+and are suggested for unmerging. \fBWARNING: Removing some
packages may cause packages which link to the removed package
to stop working and complain about missing libraries.\fR
Re\-emerge the complaining package to fix this issue.
\fBNote that changes in USE flags can drastically affect the
output of depclean.\fR
.TP
-\fBhelp\fR (\fB\-h\fR)
+.BR "help " (\fB\-h\fR)
Displays help information for emerge. Adding one of the additional
arguments listed above will give you more specific help information
on that subject. The internal \fBemerge\fR help documentation is
updated more frequently than this man page; check it out if you
are having problems that this man page does not help resolve.
.TP
-\fBinfo\fR
+.BR info
This is a list of information to include in bug reports which aids
-the developers with fixing any problems you may report. \fBPlease
+the developers with fixing any problems you may report. \fBPlease
include this information when submitting a bug report.\fR Expanded
output can be obtained with the \fI--verbose\fR option.
.TP
-\fBinject\fR (\fB\-i\fR)
+.BR "inject " (\fB\-i\fR)
Injecting a package inserts a 'stub' for that package so that Portage
-thinks that it is installed. It is handy if you need, say, a binary
+thinks that it is installed. It is handy if you need, say, a binary
version of XFree86 for esoteric hardware, or you just like to roll
your own packages. You \fBmust\fR specify a category and particular
version of a package for injecting. For example,
\fBemerge inject sys\-kernel/gentoo\-sources\-2.4.19\fR.
.TP
-\fBprune\fR (\fB\-P\fR)
+.BR "prune " (\fB\-P\fR)
\fBWARNING: This action can remove important packages!\fR Removes
all but the latest versions of matching packages. If there are
multiple SLOTs for a package, it leaves the latest version in each
-SLOT. This does no checking of dependencies, so it may remove
-packages necessary for the proper operation of your system. \fBUse\fR
+SLOT. This does no checking of dependencies, so it may remove
+packages necessary for the proper operation of your system. \fBUse\fR
clean \fBinstead unless you really know what you're doing\fR. Its
arguments can be \fIebuilds\fR, \fIclasses\fR, or \fIdependencies\fR
\-\- see \fBclean\fR above for examples.
.TP
-\fBrsync\fR
-See \fBsync\fR below.
+.BR regen
+Causes portage to check and update the dependency cache of all
+ebuilds in the portage tree. The cache is used to speed up searches
+and the building of dependency trees. This command is not recommended
+for rsync users as rsync updates the cache using server-side caches. If
+you do not know the differences between a 'rsync user' and some other
+user, then you are a 'rsync user' :). Rsync users should simply run
+\fBemerge sync\fR to regenerate the cache.
.TP
-\fBsearch\fR (\fB\-s\fR)
+.BR "search " (\fB\-s\fR)
Searches for matches of the supplied string in the portage tree.
The search string is a regular expression. For example, \fBemerge
search "^kde"\fR searches for any package that starts with "kde";
\fBemerge search "gcc$"\fR searches for any package that ends with
"gcc"; \fBemerge search "office"\fR searches for any package that
contains the word "office". If you want to search the package
-descriptions as well, use the \fB\-\-searchdesc\fR,\fB-S\fR option.
+descriptions as well, use the \fB--searchdesc\fR option.
.TP
-\fBsync\fR
+.BR sync
Initiates a portage tree update with one of the rsync.gentoo.org
mirrors. \fBNote that any changes you have made to the portage
tree will be erased\fR. Except for in special circumstances,
-this uses \fBrsync\fR to do the update. See make.conf's description
+this uses \fBrsync\fR to do the update. See \fBmake.conf\fR(5)'s description
of PORTDIR_OVERLAY for a method to avoid deletions.
.TP
-\fBunmerge\fR (\fB\-C\fR)
+.BR "unmerge " (\fB\-C\fR)
\fBWARNING: This action can remove important packages!\fR Removes
all matching packages. This does no checking of dependencies, so
it may remove packages necessary for the proper operation of your
-system. Its arguments can be \fIebuilds\fR, \fIclasses\fR, or
+system. Its arguments can be \fIebuilds\fR, \fIclasses\fR, or
\fIdependencies\fR \-\- see \fBclean\fR above for examples.
+.SH OPTIONS
.TP
-\fB\-\-version\fR
-Displays the version number of \fBemerge\fR.
-.SH "OPTIONS "
-.TP
-\fB\-\-buildpkg\fR (\fB\-b\fR)
+.BR "--buildpkg " (\fB\-b\fR)
Tells emerge to build binary packages for all ebuilds processed in
addition to actually merging the packages. Useful for maintainers
or if you administrate multiple Gentoo Linux systems (build once,
emerge tbz2s everywhere). The package will be created in the
-\fI${PKGDIR}\fR/All directory. An alternative for already-merged
+\fI${PKGDIR}/All\fR directory. An alternative for already-merged
packages is to use \fBquickpkg\fR which creates a tbz2 from the
live filesystem.
.TP
-\fB\-\-columns\fR
-Used along side \fI--pretend\fR to causes the package, new version,
+.BR "--buildpkgonly " (\fB\-B\fR)
+Creates binary packages for all ebuilds processed without actually
+merging the packages. This has the restriction that unsatisfied
+dependencies must not exist for the desired package as they cannot be
+used if they do not exist on the system.
+.TP
+.BR "--changelog " (\fB\-l\fR)
+Use this in conjunction with the \fB--pretend\fR action. This will
+show the ChangeLog entries for all the packages that will be upgraded.
+.TP
+.BR "--columns"
+Used along side \fB--pretend\fR to causes the package, new version,
and old version to be displayed in an aligned format for easy cut\-n\-paste.
.TP
-\fB\-\-debug\fR (\fB\-d\fR)
-Tells emerge to run the emerge command in \-\-debug mode. In this
+.BR "--debug " (\fB\-d\fR)
+Tells emerge to run the emerge command in \fB--debug\fR mode. In this
mode the bash build environment will run with the \-x option,
causing it to output verbose debug information to stdout.
-\-\-debug is great for finding bash syntax errors.
+\fB--debug\fR is great for finding bash syntax errors.
.TP
-\fB\-\-deep\fR
-When used in conjunction with \fB\-\-update\fR, this flag forces
+.BR "--deep " (\fB\-D\fR)
+When used in conjunction with \fB--update\fR, this flag forces
\fBemerge\fR to consider the entire dependency tree of packages,
instead of checking only the immediate dependencies of the packages.
As an example, this catches updates in libraries that are not directly
listed in the dependencies of a package.
.TP
-\fB\-\-emptytree\fR (\fB\-e\fR)
+.BR "--emptytree " (\fB\-e\fR)
Virtually tweaks the tree of installed packages to only contain glibc;
-this is great to use together with \-\-pretend. This allows developers
+this is great to use together with \fB--pretend\fR. This allows developers
to get a complete overview of the complete dependency tree of a package,
and it enables complete trees to be rebuilt using the latest libraries.
.TP
-\fB\-\-fetchonly\fR (\fB\-f\fR)
+.BR "--fetchonly " (\fB\-f\fR)
Instead of doing any package building, just perform fetches for all
packages (the main package as well as all dependencies.)
.TP
-\fB\-\-noconfmem\fR
+.BR "--noconfmem"
Causes portage to disregard merge records indicating that a config file
-inside of a CONFIG_PROTECT directory has been merged already. Portage
+inside of a \fBCONFIG_PROTECT\fR directory has been merged already. Portage
will normally merge those files only once to prevent the user from
-dealing with the same config multiple times. This flag will cause the
+dealing with the same config multiple times. This flag will cause the
file to always be merged.
.TP
-\fB\-\-nodeps\fR
+.BR "--nodeps " (\fB\-O\fR)
Merges specified packages without merging any dependencies. Note that
the build may fail if the dependencies aren't satisfied.
.TP
-\fB\-\-noreplace\fR (\fB\-n\fR)
+.BR "--noreplace " (\fB\-n\fR)
Skips the packages specified on the command\-line that have already
been installed. Without this option, any packages, ebuilds, or deps
you specify on on the command\-line *will* cause Portage to remerge
-the package, even if it is already installed. Note that Portage will
+the package, even if it is already installed. Note that Portage will
not remerge dependencies by default.
.TP
-\fB\-\-nospinner\fR
-Disables the spinner for the session. The spinner is active when the
-terminal device is determined to be a TTY. This flag disables it regardless.
+.BR "--nospinner"
+Disables the spinner for the session. The spinner is active when the
+terminal device is determined to be a TTY. This flag disables it regardless.
.TP
-\fB\-\-oneshot\fR
+.BR "--oneshot"
Emerge as normal, but do not add the packages to the world profile
for later updating.
.TP
-\fB\-\-onlydeps\fR (\fB\-o\fR)
+.BR "--onlydeps " (\fB\-o\fR)
Only merge (or pretend to merge) the dependencies of the packages
specified, not the packages themselves.
.TP
-\fB\-\-pretend\fR (\fB\-p\fR)
+.BR "--pretend " (\fB\-p\fR)
Instead of actually performing the merge, simply display what *would*
-have been installed if \-\-pretend weren't used. Using \-\-pretend
-is strongly recommended before installing an unfamiliar package. In
-the printout, N = new, U = upgrading, R = replacing, B = blocked by
+have been installed if \fB--pretend\fR weren't used. Using \fB--pretend\fR
+is strongly recommended before installing an unfamiliar package. In
+the printout, \fIN\fR = new, \fIU\fR = upgrading, \fIR\fR = replacing, \fIB\fR = blocked by
an already installed package.
.TP
-\fB\-\-searchdesc\fR (\fB\-S\fR)
+.BR "--quiet " (\fB-q\fR)
+Results may vary, but the general outcome is a reduced or condensed
+output from portage's displays.
+.TP
+.BR "--resume"
+Resumes the last merge operation. Please note that this operation
+will only return an error on failure. If there is nothing for portage
+to do, then portage will exit with a message and a success condition.
+.TP
+.BR "--searchdesc " (\fB\-S\fR)
Matches the search string against the description field as well as
the package name. \fBTake caution\fR as the descriptions are also
matched as regular expressions.
.TP
-\fB\-\-update\fR (\fB\-u\fR)
-Updates packages to the most recent version available. \fBNote that\fR \-\-update \fBdoes not have full functionality yet\fR. It will not automatically update dependencies of packages in the \fBworld\fR file, unless they too are in the \fBworld\fR file.
-.TP
-\fB\-\-usepkg\fR (\fB\-k\fR)
-Tells emerge to use binary packages (from $PKGDIR) if they are available, thus possibly avoiding some time\-consuming compiles. This option is useful for CD installs; you can export PKGDIR=/mnt/cdrom/packages and then use this option to have emerge "pull" binary packages from the CD in order to satisfy dependencies.
-.TP
-\fB\-\-verbose\fR (\fB\-v\fR)
+.BR "--skipfirst"
+This action is only valid when used with \fB--resume\fR. It removes the
+first package in the resume list so that a merge may continue in the presence
+of an uncorrectable or inconsequential error. This should only be used in
+cases where skipping the package will not result in failed dependencies.
+.TP
+.BR "--update " (\fB\-u\fR)
+Updates packages to the most recent version available. \fBNote that --update does not have full
+functionality yet\fR. It will not automatically update dependencies of packages in the \fBworld\fR file,
+unless they too are in the \fBworld\fR file.
+.TP
+.BR "--upgradeonly " (\fB-U\fR)
+Updates packages, but excludes updates that would result in a
+lower version of the package being installed. \fBSLOT\fRs are
+considered at a basic level.
+.TP
+.BR "--usepkg " (\fB\-k\fR)
+Tells emerge to use binary packages (from $PKGDIR) if they are available, thus possibly avoiding some
+time\-consuming compiles. This option is useful for CD installs; you can export PKGDIR=/mnt/cdrom/packages
+and then use this option to have emerge "pull" binary packages from the CD in order to satisfy dependencies.
+.TP
+.BR "--usepkgonly " (\fB\-K\fR)
+Behaves just as \fB--usepkg\fR except that this will only emerge
+binary packages. All the binary packages must be available at the
+time of dependency calculation or emerge will simply abort.
+.TP
+.BR "--verbose " (\fB\-v\fR)
Tell emerge to run in verbose mode. Currently this flag causes emerge to print out GNU info errors, if any.
.TP
-\fB\-\-version\fR
+.BR "--version\fR
Displays the version number of \fBemerge\fR. It cannot be used in
conjunction with other options; the name and format of the action
is a convention.
@@ -289,8 +331,8 @@ before they can emerge.
.TP
.B [ebuild U-] x11-base/xfree-4.3.0 [4.2.99.902]
The - represents lack of \fBSLOT\fR information about Xfree. This will occur
-when the previous version emerged was injected (see \fBinject\FR for more info)
-or very outdated (so old that SLOT did not exist). Either way, a newer version
+when the previous version emerged was injected (see \fBinject\fR for more info)
+or very outdated (so old that \fBSLOT\fR did not exist). Either way, a newer version
of Xfree is availabe for your updating delight.
.TP
.B [ebuild U ] net-analyzer/nmap-3.15_beta2 [3.15_beta1] -gtk -gnome
@@ -298,16 +340,19 @@ The -gtk and -gnome reflect the status of \fBUSE\fR variables when emerging nmap
we see that nmap can use the \fBUSE\fR variables gtk and gnome, but that your current
settings have gtk and gnome disabled. So optional support for gtk and gnome will
not be enabled in nmap when you emerge it.
+.br
+\fB*Note:\fR The \fBUSE\fR status is only displayed when you use the \fB--pretend\fR
+and \fB--verbose\fR options.
.SH "NOTES"
You should almost always precede any package install or update
-attempt with a \fB\-\-pretend\fR install or update. This lets
+attempt with a \fB--pretend\fR install or update. This lets
you see how much will be done, and shows you any blocking
packages that you will have to rectify. This goes doubly so
for the \fBsystem\fR and \fBworld\fR classes, which can
update a large number of packages if the portage tree has
been particularly active.
.LP
-You also want to typically use \fB\-\-update\fR, which ignores
+You also want to typically use \fB--update\fR, which ignores
packages that are already fully updated but upgrades those that
are not.
.LP
@@ -324,46 +369,45 @@ flags specified on the command line are NOT remembered\fR. For
example, \fBUSE="\-x \-gnome" emerge mc\fR will emerge mc with
those USE settings.
.LP
-If \fBemerge \-\-update system\fR or \fB emerge \-\-update world\fR
+If \fBemerge --update system\fR or \fBemerge --update world\fR
fail with an error message, it may be that an ebuild uses some
newer feature not present in this version of \fBemerge\fR. You
-can use \fBemerge \-\-update portage\fR to upgrade to the lastest
+can use \fBemerge --update portage\fR to upgrade to the lastest
version, which should support any necessary new features.
.SH "MASKED PACKAGES"
-\fINOTE: Please use caution when using development packages. Problems
+\fINOTE: Please use caution when using development packages. Problems
and bugs resulting from misusing masked packages drains Gentoo
-developer time. Please be sure you are capable of handling problems
+developer time. Please be sure you are capable of handling problems
that may ensue.\fR
.LP
Masks in \fBportage\fR provide three primary functions: they allow a
testing period where the packages can be used in live machines; they
prevent the use of a package when it will fail, and they mask existing
packages that are broken or could pose a security risk. Masking can be
-done by two methods: \fBpackage.mask\fR and KEYWORDS.
+done by two methods: \fBpackage.mask\fR and \fBKEYWORDS\fR.
.TP
-\fBpackage.mask\fR
+.BR package.mask
\fBpackage.mask\fR primarily blocks the use of packages that cause
-problems or are known to have issues on disparate systems. It resides in
-\fI${PORTDIR}/profiles\fR. Packages may be unmasked in the file by adding
+problems or are known to have issues on disparate systems. It resides in
+\fI${PORTDIR}/profiles\fR. Packages may be unmasked in the file by adding
a comment character (\fB#\fR) to the beginning of the line which masks
the package.
.TP
-\fBKEYWORDS\fR
-KEYWORDS are also used for masking packages still in testing. There are
+.BR KEYWORDS
+\fBKEYWORDS\fR are also used for masking packages still in testing. There are
architecture\-specific keywords for each package that let \fBportage\fR
know which systems are compatible with the package. Packages which
compile on an architecture, but have not been proven to be "stable",
are masked with a tilde (\fB~\fR) in front of the architecture name.
\fBemerge\fR examines the \fBACCEPT_KEYWORDS\fR environment variable
-to allow or disallow the emerging of a package masked by a KEYWORD.
-To inform \fBemerge\fR that it should build these 'testing' versions
+to allow or disallow the emerging of a package masked by \fBKEYWORDS. To
+inform \fBemerge\fR that it should build these 'testing' versions
of packages, you may set \fBACCEPT_KEYWORDS\fR to "\fB~arch\fR", where
-\fBarch\fR is one of \fBx86\fR, \fBppc\fR, \fBsparc\fR, \fBsparc64\fR,
-or \fBalpha\fR. For example, \fBACCEPT_KEYWORDS="~x86" emerge xfree\fR
-will cause \fBemerge\fR to consider KEYWORDS\-masked versions of XFree
-it decides the packages to build. \fBWARNING:\fR Do \fInot\fR set this
-variable to anything other than the value corresponding to your
-architecture.
+\fBarch\fR is one of: \fIx86 ppc sparc mips alpha arm hppa\fR. For example,
+\fBACCEPT_KEYWORDS="~x86" emerge xfree\fR will cause \fBemerge\fR to consider
+\fBKEYWORDS\fR\-masked versions of XFree as potentional upgrade
+canidates. \fBWARNING:\fR Do \fInot\fR set this variable to anything
+other than the value corresponding to your architecture.
.SH "REPORTING BUGS"
Please report any bugs you encounter through our website:
.LP
@@ -372,14 +416,14 @@ Please report any bugs you encounter through our website:
Please include the output of \fBemerge info\fR when you submit your
bug report.
.SH "SEE ALSO"
-.BR emerge --help,
+.BR "emerge --help",
.BR ebuild (1),
.BR ebuild (5),
.BR make.conf (5)
-.LP
+.LP
A number of helper applications reside in \fI/usr/lib/portage/bin\fR.
-.LP
-The \fBgentoolkit\fR package contains useful scripts such as \fBqpkg\fR
+.LP
+The \fBapp-admin/gentoolkit\fR package contains useful scripts such as \fBqpkg\fR
(a package query tool).
.SH "FILES"
.TP
@@ -390,37 +434,37 @@ class updates and removing those that you do not want to be considered.
.TP
\fB/etc/make.conf\fR
Contains variables for the build process, overriding those in
-\fBmake.globals\fR. \fBYou should edit this file instead of the ones
+\fBmake.globals\fR. \fBYou should edit this file instead of the ones
listed below\fR.
.TP
\fB/etc/make.profile/make.defaults\fR
-Contains profile\-specific variables for the build process. \fBDo not
+Contains profile\-specific variables for the build process. \fBDo not
edit this file\fR.
.TP
\fB/etc/make.profile/use.defaults\fR
-Contains the USE flags that are enabled by default. \fBDo not edit this
+Contains the USE flags that are enabled by default. \fBDo not edit this
file\fR.
.TP
\fB/usr/portage/profiles/use.desc\fR
Contains the master list of USE flags with descriptions of their
-functions. \fBDo not edit this file\fR.
+functions. \fBDo not edit this file\fR.
.TP
\fB/etc/make.profile/virtuals\fR
Contains a list of default packages used to resolve virtual dependencies.
\fBDo not edit this file\fR.
.TP
\fB/var/cache/edb/virtuals\fR
-Contains a list of packages used to resolve virtual dependencies. In the
+Contains a list of packages used to resolve virtual dependencies. In the
case of failing virtual matches, you may reorder the entries for the
-corresponding virtual here. The first package listed after the virtual is
+corresponding virtual here. The first package listed after the virtual is
the entry used for matching the virtual.
.TP
\fB/etc/make.profile/package\fR
-Contains a list of packages used for the base system. The \fBsystem\fR
-and \fBworld\fR classes consult this file. \fBDo not edit this file\fR.
+Contains a list of packages used for the base system. The \fBsystem\fR
+and \fBworld\fR classes consult this file. \fBDo not edit this file\fR.
.TP
\fB/etc/make.globals\fR
-Contains the default variables for the build process. \fBDo not edit
+Contains the default variables for the build process. \fBDo not edit
this file\fR.
.SH "AUTHORS"
Daniel Robbins <drobbins@gentoo.org>
@@ -432,5 +476,7 @@ Achim Gottinger <achim@gentoo.org>
Nicholas Jones <carpaski@gentoo.org>
.br
Phil Bordelon <sunflare@gentoo.org>
+.br
+Mike Frysinger <vapier@gentoo.org>
.SH "CVS HEADER"
-$Id: emerge.1,v 1.37 2003/05/20 09:16:00 carpaski Exp $
+$Id: emerge.1,v 1.38 2003/06/12 19:19:13 vapier Exp $